{"id":"CVE-2026-115916","title":"vLLM: Out-of-vocabulary prompt token id passes input validation and triggers a CUDA device-side assert (engine crash / DoS)","summary":"vLLM is an inference and serving engine for large language models. Prior to 0.32.0, vllm/tokenizers/hf.py computes max_token_id with an off-by-one upper bound, allowing a pre-tokenized prompt ID equal to the vocabulary size to pass valid…","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","cvssSource":"cna","cwe":["CWE-129","CWE-193"],"vendor":"vllm-project","product":"vllm","affected":["vllm < 0.32.0"],"published":"2026-10-26","updated":"2026-10-26","sourceUpdated":"2026-10-26T17:18:17.582Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-115916","references":[{"url":"https://github.com/vllm-project/vllm/security/advisories/GHSA-q97c-p368-75c4","label":"https://github.com/vllm-project/vllm/security/advisories/GHSA-q97c-p368-75c4"},{"url":"https://github.com/vllm-project/vllm/pull/59491","label":"https://github.com/vllm-project/vllm/pull/59491"},{"url":"https://github.com/vllm-project/vllm/commit/37cecc8141e2dcba9dd534897a164d4baaf27229","label":"https://github.com/vllm-project/vllm/commit/37cecc8141e2dcba9dd534897a164d4baaf27229"},{"url":"https://github.com/vllm-project/vllm/releases/tag/v0.32.0","label":"https://github.com/vllm-project/vllm/releases/tag/v0.32.0"}],"tags":["cve.org"],"ingestedAt":"2026-10-26T17:33:33.057Z","epss":0.00305,"epssPercentile":0.23131,"slug":"CVE-2026-115916","body":"## Overview\n\nvLLM is an inference and serving engine for large language models. Prior to 0.32.0, vllm/tokenizers/hf.py computes max_token_id with an off-by-one upper bound, allowing a pre-tokenized prompt ID equal to the vocabulary size to pass validation. For a tensor-parallel size of one and an exact multiple-of-64 vocabulary, VocabParallelEmbedding.forward does not mask that value before F.embedding uses it, causing a CUDA device-side assertion and terminating the engine. This issue is fixed in version 0.32.0.\n\n## Affected\n\n- `vllm < 0.32.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}