{"id":"CVE-2026-118500","title":"Cool FormKit Lite <= 2.7.9 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via Form Field custom_id Parameter","summary":"The Cool FormKit Lite – Advanced Form Builder for Elementor plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the '_elementor_data.form_fields[].custom_id' parameter in all versions up to, and including, 2.7…","severity":"medium","cvss":6.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","cvssSource":"cna","cwe":["CWE-79"],"vendor":"coolplugins","product":"Cool FormKit Lite – Advanced Form Builder for Elementor","affected":["cool_formkit_lite_advanced_form_builder_for_elementor <= 2.7.9"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-30T15:20:48.539470Z"},"published":"2026-10-30","updated":"2026-10-30","sourceUpdated":"2026-10-30T15:57:46.333Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-118500","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/94c6ee49-604d-4183-bd47-7ab2732de6b4?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/extensions-for-elementor-form/tags/2.7.9/assets/js/shared/logic-frontend.js#L719"},{"url":"https://plugins.trac.wordpress.org/browser/extensions-for-elementor-form/tags/2.7.9/includes/fields/conditional-fields-trait.php#L753"},{"url":"https://plugins.trac.wordpress.org/browser/extensions-for-elementor-form/tags/2.7.9/includes/fields/conditional-fields-trait.php#L704"},{"url":"https://plugins.trac.wordpress.org/browser/extensions-for-elementor-form/tags/2.7.9/modules/forms/widgets/cool-form.php#L711"},{"url":"https://github.com/CoolPluginsTeam/extensions-for-elementor-form/pull/90"},{"url":"https://plugins.trac.wordpress.org/changeset/3772891/extensions-for-elementor-form/trunk/assets/js/shared/logic-frontend.js"}],"tags":["cve.org"],"epss":0.00216,"epssPercentile":0.12099,"ingestedAt":"2026-11-05T16:24:31.047Z","slug":"CVE-2026-118500","body":"## Overview\n\nThe Cool FormKit Lite – Advanced Form Builder for Elementor plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the '_elementor_data.form_fields[].custom_id' parameter in all versions up to, and including, 2.7.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The esc_html() call applied at server emission is bypassed because the HTML fragment-serialization algorithm restores &quot; to a raw double-quote inside text nodes when jQuery .html() extracts the template, allowing the attacker-controlled custom_id to break out of an HTML attribute context within the plugin's own frontend script.\n\n## Affected\n\n- `cool_formkit_lite_advanced_form_builder_for_elementor <= 2.7.9`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":35,"depthScoreParts":{"impact":35.2,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}