{"id":"CVE-2026-119978","title":"Flowise through 3.1.4 Custom Function Sandbox Escape RCE via LocalFileStore","summary":"Flowise through 3.1.4 contains a sandbox escape vulnerability that allows authenticated users to execute OS commands by abusing allowlisted langchain and mammoth modules when ALLOW_BUILTIN_DEP=true. Attackers can submit JavaScript to /ap…","severity":"high","cvss":8.5,"cvssVector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-749"],"vendor":"FlowiseAI","product":"Flowise","affected":["Flowise <= 3.1.4"],"published":"2026-10-30","updated":"2026-11-02","sourceUpdated":"2026-11-02T20:53:41.605Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-119978","references":[{"url":"https://github.com/soovwv/cve/blob/a37354aff1e78c0601772e7716f5318c473e8640/CVE-2026-119978.md","label":"Researcher write-up"},{"url":"https://github.com/FlowiseAI/Flowise/blob/a65f81bb43ef66d3ce734bf0dff4223ae8041c95/packages/components/src/utils.ts#L55-L114"},{"url":"https://github.com/FlowiseAI/Flowise/blob/a65f81bb43ef66d3ce734bf0dff4223ae8041c95/packages/components/src/utils.ts#L1733"},{"url":"https://github.com/advisories/GHSA-9gvv-qjj3-2p6g","label":"GitHub Security Advisory (GHSA-9gvv-qjj3-2p6g)"},{"url":"https://github.com/FlowiseAI/Flowise"},{"url":"https://www.vulncheck.com/advisories/flowise-through-3.1.4-custom-function-sandbox-escape-rce-via-localfilestore","label":"VulnCheck Advisory: Flowise through 3.1.4 Custom Function Sandbox Escape RCE via LocalFileStore"}],"tags":["cve.org"],"epss":0.00337,"epssPercentile":0.27316,"ingestedAt":"2026-11-05T19:30:42.846Z","slug":"CVE-2026-119978","body":"## Overview\n\nFlowise through 3.1.4 contains a sandbox escape vulnerability that allows authenticated users to execute OS commands by abusing allowlisted langchain and mammoth modules when ALLOW_BUILTIN_DEP=true. Attackers can submit JavaScript to /api/v1/node-custom-function that writes a file into the mammoth package via LocalFileStore and requires it, escaping vm2 as the Flowise process user.\n\n## Affected\n\n- `Flowise <= 3.1.4`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":47,"depthScoreParts":{"impact":46.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}