{"id":"CVE-2026-121414","title":"Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 Denial of Service via afterSave Pointer Update","summary":"Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 fails to contain a serialization error when an object update uses a dot notation key targeting a pointer field's object identifier on a class with an afterSave trigger. Attacker…","severity":"medium","cvss":5.9,"cvssVector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","cvssSource":"cna","cwe":["CWE-248"],"vendor":"parse-community","product":"parse-server","affected":["parse-server >= 9.0.0 < 9.10.6-alpha.2","parse-server < 8.6.110"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-11-07T02:54:29.294146Z"},"published":"2026-11-03","updated":"2026-11-07","sourceUpdated":"2026-11-07T02:54:38.073Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-121414","references":[{"url":"https://github.com/parse-community/parse-server/security/advisories/GHSA-wc3c-6843-q7mv","label":"GitHub Security Advisory (GHSA-wc3c-6843-q7mv)"},{"url":"https://github.com/parse-community/parse-server/pull/10802"},{"url":"https://github.com/parse-community/parse-server/pull/10803"},{"url":"https://www.vulncheck.com/advisories/parse-server-before-8.6.110-and-9.0.0-before-9.10.6-alpha.2-denial-of-service-via-aftersave-pointer-update","label":"VulnCheck Advisory: Parse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 Denial of Service via afterSave Pointer Update"}],"tags":["cve.org"],"epss":0.00334,"epssPercentile":0.26925,"ingestedAt":"2026-11-05T19:30:42.965Z","slug":"CVE-2026-121414","body":"## Overview\n\nParse Server before 8.6.110 and 9.0.0 before 9.10.6-alpha.2 fails to contain a serialization error when an object update uses a dot notation key targeting a pointer field's object identifier on a class with an afterSave trigger. Attackers, including unauthenticated clients when objects are writable without a session, can send such an update to crash the Node process.\n\n## Affected\n\n- `parse-server >= 9.0.0 < 9.10.6-alpha.2`\n- `parse-server < 8.6.110`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":33,"depthScoreParts":{"impact":32.5,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}