{"id":"CVE-2026-121652","title":"Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering","summary":"Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON featu…","severity":"medium","cvss":5.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","cvssSource":"cna","cwe":["CWE-79"],"vendor":"AWS","product":"maplibre-gl-js-amplify","affected":["maplibre-gl-js-amplify < 4.0.3"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-11-03T20:00:46.727903Z"},"published":"2026-11-03","updated":"2026-11-03","sourceUpdated":"2026-11-03T20:01:00.960Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-121652","references":[{"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3"},{"url":"https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9"},{"url":"https://aws.amazon.com/security/security-bulletins/2026-167-aws/"}],"tags":["cve.org"],"epss":0.00264,"epssPercentile":0.18336,"ingestedAt":"2026-11-05T20:33:06.427Z","slug":"CVE-2026-121652","body":"## Overview\n\nCross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl.\n\n\n\nTo remediate this issue, users should upgrade to 4.0.3 or later.\n\n## Affected\n\n- `maplibre-gl-js-amplify < 4.0.3`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":30,"depthScoreParts":{"impact":29.7,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}