{"id":"CVE-2026-121967","title":"Coder before 2.29.22, 2.34.13, 2.35.10, 2.36.8, 2.37.5, and 2.38.1 AI Gateway Path Traversal","summary":"Coder 2.28.0 before 2.29.22, 2.30.0 before 2.34.13, 2.35.0 before 2.35.10, 2.36.0 before 2.36.8, 2.37.0 before 2.37.5, and 2.38.0 before 2.38.1 contains a path traversal vulnerability in the AI Gateway passthrough router, which forwards …","severity":"medium","cvss":4.9,"cvssVector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N","cvssSource":"cna","cwe":["CWE-22"],"vendor":"coder","product":"coder","affected":["coder >= 2.37.0 < 2.37.5","coder >= 2.36.0 < 2.36.8","coder >= 2.35.0 < 2.35.10","coder >= 2.30.0 < 2.34.13","coder >= 2.28.0 < 2.29.22","coder >= 2.38.0 < 2.38.1"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-11-04T18:13:18.040579Z"},"published":"2026-11-04","updated":"2026-11-04","sourceUpdated":"2026-11-04T18:13:30.807Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-121967","references":[{"url":"https://github.com/coder/coder/security/advisories/GHSA-373r-678h-hjc6","label":"GitHub Security Advisory (GHSA-373r-678h-hjc6)"},{"url":"https://github.com/coder/coder/pull/30178","label":"GitHub Pull Request #30178"},{"url":"https://www.vulncheck.com/advisories/coder-before-2.29.22-2.34.13-2.35.10-2.36.8-2.37.5-and-2.38.1-ai-gateway-path-traversal","label":"VulnCheck Advisory: Coder before 2.29.22, 2.34.13, 2.35.10, 2.36.8, 2.37.5, and 2.38.1 AI Gateway Path Traversal"}],"tags":["cve.org"],"ingestedAt":"2026-11-05T21:36:00.481Z","epss":0.00256,"epssPercentile":0.17322,"slug":"CVE-2026-121967","body":"## Overview\n\nCoder 2.28.0 before 2.29.22, 2.30.0 before 2.34.13, 2.35.0 before 2.35.10, 2.36.0 before 2.36.8, 2.37.0 before 2.37.5, and 2.38.0 before 2.38.1 contains a path traversal vulnerability in the AI Gateway passthrough router, which forwards percent-encoded dot segments upstream without rejecting them. Authenticated users can send paths such as %2e%2e or ..%2F under allowlisted prefixes to reach unintended provider endpoints using the deployment's centrally managed provider key.\n\n## Affected\n\n- `coder >= 2.37.0 < 2.37.5`\n- `coder >= 2.36.0 < 2.36.8`\n- `coder >= 2.35.0 < 2.35.10`\n- `coder >= 2.30.0 < 2.34.13`\n- `coder >= 2.28.0 < 2.29.22`\n- `coder >= 2.38.0 < 2.38.1`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":27,"depthScoreParts":{"impact":27,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}