{"id":"CVE-2026-123545","title":"OpenAM 14.5.1 before 16.1.4 CSRF in OAuth 2.0 Device Flow","summary":"OpenAM from 14.5.1 before 16.1.4 contains a cross-site request forgery vulnerability in the OAuth 2.0 device authorization flow that allows attackers to approve device codes when consent is skipped for implied-consent clients. Attackers …","severity":"high","cvss":7.1,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N","cvssSource":"cna","cwe":["CWE-352"],"vendor":"OpenIdentityPlatform","product":"OpenAM","affected":["OpenAM >= 14.5.1 < 16.1.4"],"published":"2026-11-08","updated":"2026-11-08","sourceUpdated":"2026-11-08T01:37:50.701Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-123545","references":[{"url":"https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-545c-rm35-2jj2","label":"GitHub Security Advisory (GHSA-545c-rm35-2jj2)"},{"url":"https://www.vulncheck.com/advisories/openam-14.5.1-before-16.1.4-csrf-in-oauth-2.0-device-flow","label":"VulnCheck Advisory: OpenAM 14.5.1 before 16.1.4 CSRF in OAuth 2.0 Device Flow"}],"tags":["cve.org"],"ingestedAt":"2026-11-08T02:43:18.678Z","slug":"CVE-2026-123545","body":"## Overview\n\nOpenAM from 14.5.1 before 16.1.4 contains a cross-site request forgery vulnerability in the OAuth 2.0 device authorization flow that allows attackers to approve device codes when consent is skipped for implied-consent clients. Attackers can start a device authorization and lure a logged-in user to a crafted page, obtaining access and ID tokens to call APIs as that user.\n\n## Affected\n\n- `OpenAM >= 14.5.1 < 16.1.4`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":39,"depthScoreParts":{"impact":39.1,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}