{"id":"CVE-2026-17114","title":"Multiple Vulnerabilities in IBM API Connect","summary":"IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information and cause a denial of service due to the generation of error messages containing sensiti…","severity":"medium","cvss":5.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L","cvssSource":"cna","cwe":["CWE-209"],"vendor":"IBM","product":"API Connect","affected":["api_connect >= 12.1.0.0 <= 12.1.1.2","api_connect >= 10.0.8.0 <= 10.0.8.12"],"published":"2026-11-07","updated":"2026-11-07","sourceUpdated":"2026-11-07T04:31:48.362Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-17114","references":[{"url":"https://www.ibm.com/support/pages/node/7295635"},{"url":"https://www.ibm.com/support/pages/node/7295637"}],"tags":["cve.org"],"ingestedAt":"2026-11-07T05:10:28.984Z","epss":0.00421,"epssPercentile":0.3672,"slug":"CVE-2026-17114","body":"## Overview\n\nIBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information and cause a denial of service due to the generation of error messages containing sensitive information.\n\n## Affected\n\n- `api_connect >= 12.1.0.0 <= 12.1.1.2`\n- `api_connect >= 10.0.8.0 <= 10.0.8.12`\n\n## Remediation\n\nIBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3\nFix Central Link:  https://www.ibm.com/support/pages/node/7290205 \n\n\n\nIBM strongly recommends addressing the vulnerability now by upgrading to 10.0.8.13Fix Central Link: https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/IBM+API+Connect&release=10.0.8.12&platform=All&function=all","depth":"sunlit","depthScore":30,"depthScoreParts":{"impact":29.7,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}