{"id":"CVE-2026-21892","title":"Parsl is a Python parallel scripting library","summary":"Parsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator…","severity":"medium","cvss":5.3,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","cwe":["CWE-89"],"vendor":"uchicago","product":"parsl","affected":["parsl < 2026.01.05"],"patched":["parsl 2026.01.05"],"published":"2026-01-08","updated":"2026-10-06","sourceUpdated":"2026-10-06T22:10:00.247","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-21892","references":[{"url":"https://github.com/Parsl/parsl/commit/013a928461e70f38a33258bd525a351ed828e974","label":"security-advisories@github.com"},{"url":"https://github.com/Parsl/parsl/security/advisories/GHSA-f2mf-q878-gh58","label":"security-advisories@github.com"},{"url":"https://github.com/Parsl/parsl/security/advisories/GHSA-f2mf-q878-gh58","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-21892"},{"url":"https://github.com/Parsl/parsl"}],"tags":["nvd","osv","pip"],"epss":0.00275,"epssPercentile":0.19844,"aliases":["GHSA-f2mf-q878-gh58","PYSEC-2026-1759"],"ecosystem":"pip","ingestedAt":"2026-07-08T18:25:48.623Z","slug":"CVE-2026-21892","body":"## Overview\n\nParsl is a Python parallel scripting library. A SQL Injection vulnerability exists in the parsl-visualize component of versions prior to 2026.01.05. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflow_id) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Version 2026.01.05 fixes the issue.\n\n## Affected\n\n- `parsl < 2026.01.05`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `parsl 2026.01.05`\n\n## Package advisory (CVE-2026-21892)\n\nAffected packages:\n\n- `parsl < 2026.01.05`\n\nPatched in:\n\n- `parsl 2026.01.05`\n\nSource: https://osv.dev/vulnerability/GHSA-f2mf-q878-gh58","depth":"sunlit","depthScore":29,"depthScoreParts":{"impact":29.2,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}