{"id":"CVE-2026-44796","title":"Nautobot is a Network Source of Truth and Network Automation Platform","summary":"Nautobot is a Network Source of Truth and Network Automation Platform. Prior to 2.4.33 and 3.1.2, Nautobot UI object-bulk-rename endpoints (for example, /dcim/interfaces/rename/) were vulnerable to application-wide denial of service via …","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","cwe":["CWE-400","CWE-1333"],"vendor":"networktocode","product":"nautobot","affected":["nautobot < 2.4.33","nautobot >= 3.0.0, < 3.1.2"],"patched":["nautobot 3.1.2"],"published":"2026-05-28","updated":"2026-10-14","sourceUpdated":"2026-10-14T20:10:00.190","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-44796","references":[{"url":"https://github.com/nautobot/nautobot/commit/5a30d0916953afbeedd24a784709e762cc3879cd","label":"security-advisories@github.com"},{"url":"https://github.com/nautobot/nautobot/commit/c2b766966d814a7141f62c7bc90c85fefb7892ee","label":"security-advisories@github.com"},{"url":"https://github.com/nautobot/nautobot/releases/tag/v2.4.33","label":"security-advisories@github.com"},{"url":"https://github.com/nautobot/nautobot/releases/tag/v3.1.2","label":"security-advisories@github.com"},{"url":"https://github.com/nautobot/nautobot/security/advisories/GHSA-qrpw-gjvh-x5gm","label":"security-advisories@github.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-44796"},{"url":"https://github.com/nautobot/nautobot"}],"tags":["nvd","osv","pip"],"epss":0.00312,"epssPercentile":0.23913,"aliases":["GHSA-qrpw-gjvh-x5gm","PYSEC-2026-2226"],"ecosystem":"pip","ingestedAt":"2026-07-13T18:58:02.244Z","slug":"CVE-2026-44796","body":"## Overview\n\nNautobot is a Network Source of Truth and Network Automation Platform. Prior to 2.4.33 and 3.1.2, Nautobot UI object-bulk-rename endpoints (for example, /dcim/interfaces/rename/) were vulnerable to application-wide denial of service via maliciously crafted regular expressions in the find field in combination with the use_regex flag. This vulnerability is fixed in 2.4.33 and 3.1.2.\n\n## Affected\n\n- `nautobot < 2.4.33`\n- `nautobot >= 3.0.0, < 3.1.2`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `nautobot 3.1.2`\n\n## Package advisory (CVE-2026-44796)\n\nAffected packages:\n\n- `nautobot >= 3.0.0a2, < 3.1.2`\n- `nautobot < 2.4.33`\n\nPatched in:\n\n- `nautobot 3.1.2`\n- `nautobot 2.4.33`\n\nSource: https://osv.dev/vulnerability/GHSA-qrpw-gjvh-x5gm","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}