{"id":"CVE-2026-55957","aliases":["GHSA-7895-gffq-w6jq"],"title":"Apache Tomcat has a Missing Critical Step in Authentication vulnerability","summary":"Apache Tomcat has a Missing Critical Step in Authentication vulnerability","severity":"high","cvss":7.3,"cwe":["CWE-304"],"vendor":"apache","product":"org.apache.tomcat.embed:tomcat-embed-core","ecosystem":"maven","affected":["org.apache.tomcat.embed:tomcat-embed-core >= 11.0.0-M1, < 11.0.5","org.apache.tomcat.embed:tomcat-embed-core >= 10.1.0-M1, < 10.1.37","org.apache.tomcat.embed:tomcat-embed-core >= 9.0.0.M1, < 9.0.101","org.apache.tomcat.embed:tomcat-embed-core >= 8.5.0, <= 8.5.100","org.apache.tomcat.embed:tomcat-embed-core <= 7.0.109","org.apache.tomcat:tomcat >= 11.0.0-M1, < 11.0.5","org.apache.tomcat:tomcat >= 10.1.0-M1, < 10.1.37","org.apache.tomcat:tomcat >= 9.0.0.M1, < 9.0.101","org.apache.tomcat:tomcat >= 8.5.0, <= 8.5.100","org.apache.tomcat:tomcat <= 7.0.109","org.apache.tomcat:tomcat-catalina >= 11.0.0-M1, < 11.0.5","org.apache.tomcat:tomcat-catalina >= 10.1.0-M1, < 10.1.37","org.apache.tomcat:tomcat-catalina >= 9.0.0.M1, < 9.0.101","org.apache.tomcat:tomcat-catalina >= 8.5.0, <= 8.5.100","org.apache.tomcat:tomcat-catalina <= 7.0.109"],"patched":["org.apache.tomcat.embed:tomcat-embed-core 11.0.5","org.apache.tomcat.embed:tomcat-embed-core 10.1.37","org.apache.tomcat.embed:tomcat-embed-core 9.0.101","org.apache.tomcat:tomcat 11.0.5","org.apache.tomcat:tomcat 10.1.37","org.apache.tomcat:tomcat 9.0.101","org.apache.tomcat:tomcat-catalina 11.0.5","org.apache.tomcat:tomcat-catalina 10.1.37","org.apache.tomcat:tomcat-catalina 9.0.101"],"published":"2026-06-29","updated":"2026-11-04","sourceUpdated":"2026-11-04T16:22:00Z","source":"GHSA","sourceUrl":"https://github.com/advisories/GHSA-7895-gffq-w6jq","references":[{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-55957"},{"url":"https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjh"},{"url":"http://www.openwall.com/lists/oss-security/2026/06/29/26"},{"url":"https://github.com/apache/tomcat/commit/0cd21c0393b8811af22daddbba7b4e7328e2d79e"},{"url":"https://github.com/apache/tomcat/commit/c32bbd37ea9ee0aaab848af4ee1c9a76e84240ea"},{"url":"https://github.com/apache/tomcat/commit/fd96ab415631eea44636c94f911dd38427070ef9"},{"url":"https://tomcat.apache.org/security-10.html"},{"url":"https://tomcat.apache.org/security-11.html"},{"url":"https://tomcat.apache.org/security-9.html"},{"url":"https://github.com/advisories/GHSA-7895-gffq-w6jq"}],"tags":["ghsa","maven","exploit-available"],"epss":0.02855,"epssPercentile":0.86771,"exploits":{"github":1,"githubRepos":["https://github.com/mdvpat/CVE-2026-55957-PoC"],"checkedAt":"2026-11-05T15:45:35.632Z"},"exploitAvailable":true,"ingestedAt":"2026-11-04T17:19:45.136Z","slug":"CVE-2026-55957","body":"## Overview\n\nMissing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without providing the correct password.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.\n\nUsers are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.\n\n## Affected packages\n\n- `org.apache.tomcat.embed:tomcat-embed-core >= 11.0.0-M1, < 11.0.5`\n- `org.apache.tomcat.embed:tomcat-embed-core >= 10.1.0-M1, < 10.1.37`\n- `org.apache.tomcat.embed:tomcat-embed-core >= 9.0.0.M1, < 9.0.101`\n- `org.apache.tomcat.embed:tomcat-embed-core >= 8.5.0, <= 8.5.100`\n- `org.apache.tomcat.embed:tomcat-embed-core <= 7.0.109`\n- `org.apache.tomcat:tomcat >= 11.0.0-M1, < 11.0.5`\n- `org.apache.tomcat:tomcat >= 10.1.0-M1, < 10.1.37`\n- `org.apache.tomcat:tomcat >= 9.0.0.M1, < 9.0.101`\n- `org.apache.tomcat:tomcat >= 8.5.0, <= 8.5.100`\n- `org.apache.tomcat:tomcat <= 7.0.109`\n- `org.apache.tomcat:tomcat-catalina >= 11.0.0-M1, < 11.0.5`\n- `org.apache.tomcat:tomcat-catalina >= 10.1.0-M1, < 10.1.37`\n- `org.apache.tomcat:tomcat-catalina >= 9.0.0.M1, < 9.0.101`\n- `org.apache.tomcat:tomcat-catalina >= 8.5.0, <= 8.5.100`\n- `org.apache.tomcat:tomcat-catalina <= 7.0.109`\n\n## Remediation\n\nUpgrade to a patched release:\n\n- `org.apache.tomcat.embed:tomcat-embed-core 11.0.5`\n- `org.apache.tomcat.embed:tomcat-embed-core 10.1.37`\n- `org.apache.tomcat.embed:tomcat-embed-core 9.0.101`\n- `org.apache.tomcat:tomcat 11.0.5`\n- `org.apache.tomcat:tomcat 10.1.37`\n- `org.apache.tomcat:tomcat 9.0.101`\n- `org.apache.tomcat:tomcat-catalina 11.0.5`\n- `org.apache.tomcat:tomcat-catalina 10.1.37`\n- `org.apache.tomcat:tomcat-catalina 9.0.101`","depth":"midnight","depthScore":53,"depthScoreParts":{"impact":40.2,"likelihood":0.6,"exploitation":12,"ransomware":0},"changes":[]}