{"id":"CVE-2026-56838","title":"PraisonAI recipe.run_stream skips dangerous-tool policy enforcement","summary":"PraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.59, PraisonAI recipe execution blocks default-denied dangerous tools unless the caller explicitly passes allow_dangerous_tools=True. The normal recipe.run…","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-78","CWE-693","CWE-863"],"vendor":"MervinPraison","product":"PraisonAI","affected":["PraisonAI >= 4.5.87, < 4.6.59"],"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"total","timestamp":"2026-10-29T13:52:31.231130Z"},"exploitAvailable":true,"published":"2026-10-23","updated":"2026-10-29","sourceUpdated":"2026-10-29T13:53:23.978Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-56838","references":[{"url":"https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-v847-hxxw-3pxg","label":"https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-v847-hxxw-3pxg"},{"url":"https://github.com/MervinPraison/PraisonAI"}],"tags":["cve.org","exploit-available","osv","pip"],"epss":0.00146,"epssPercentile":0.03841,"aliases":["GHSA-v847-hxxw-3pxg"],"ecosystem":"pip","patched":["praisonai 4.6.59"],"ingestedAt":"2026-07-21T19:04:57.649Z","slug":"CVE-2026-56838","body":"## Overview\n\nPraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.59, PraisonAI recipe execution blocks default-denied dangerous tools unless the caller explicitly passes allow_dangerous_tools=True. The normal recipe.run() path enforces this with _check_tool_policy(). The streaming path, recipe.run_stream(), loads the same recipe, checks dependencies, and then calls _execute_recipe() without running the dangerous-tool policy check. As a result, a recipe that honestly declares execute_command in TEMPLATE.yaml requires.tools is denied by recipe.run(), but reaches the execution engine through recipe.run_stream() with allow_dangerous_tools=False. This issue has been patched in version 4.6.59.\n\n## Affected\n\n- `PraisonAI >= 4.5.87, < 4.6.59`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-56838)\n\nAffected packages:\n\n- `praisonai >= 4.5.87, < 4.6.59`\n\nPatched in:\n\n- `praisonai 4.6.59`\n\nSource: https://osv.dev/vulnerability/GHSA-v847-hxxw-3pxg","depth":"midnight","depthScore":55,"depthScoreParts":{"impact":42.9,"likelihood":0,"exploitation":12,"ransomware":0},"changes":[{"seq":231825,"id":"CVE-2026-56838","ts":1793559591795,"field":"exploit_available","old":"false","new":"true"}]}