{"id":"CVE-2026-57117","title":"PraisonAI: Compute-bridged file tools allow shell command injection","summary":"PraisonAI is a multi-agent teams system. From version 4.6.10 to before version 4.6.59, LocalManagedAgent / SandboxedAgent compute bridging wraps read_file, list_files, and write_file when a compute provider is attached. The bridge conver…","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-78","CWE-863"],"vendor":"MervinPraison","product":"PraisonAI","affected":["PraisonAI >= 4.6.10, < 4.6.59"],"published":"2026-10-23","updated":"2026-10-23","sourceUpdated":"2026-10-23T12:10:18.920Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-57117","references":[{"url":"https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-w6h2-fr4q-xvxv","label":"https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-w6h2-fr4q-xvxv"},{"url":"https://github.com/MervinPraison/PraisonAI"}],"tags":["cve.org","osv","pip"],"aliases":["GHSA-w6h2-fr4q-xvxv"],"ecosystem":"pip","patched":["praisonai 4.6.59"],"ingestedAt":"2026-07-21T19:04:57.799Z","epss":0.00401,"epssPercentile":0.34217,"slug":"CVE-2026-57117","body":"## Overview\n\nPraisonAI is a multi-agent teams system. From version 4.6.10 to before version 4.6.59, LocalManagedAgent / SandboxedAgent compute bridging wraps read_file, list_files, and write_file when a compute provider is attached. The bridge converts those file operations into shell command strings using raw path arguments, then sends those strings to shell-backed compute providers. An attacker who can influence a file-tool path argument can break out of the quoted path and execute arbitrary shell commands in the compute environment. With compute=\"local\", commands execute through the local subprocess compute provider on the host. With Docker, commands execute in the container. This issue has been patched in version 4.6.59.\n\n## Affected\n\n- `PraisonAI >= 4.6.10, < 4.6.59`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-57117)\n\nAffected packages:\n\n- `praisonai >= 4.6.10, < 4.6.59`\n\nPatched in:\n\n- `praisonai 4.6.59`\n\nSource: https://osv.dev/vulnerability/GHSA-w6h2-fr4q-xvxv","depth":"twilight","depthScore":48,"depthScoreParts":{"impact":48.4,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}