{"id":"CVE-2026-58451","title":"Horde IMP < 7.0.1 Path Traversal via Compose.php img src","summary":"Horde IMP before 7.0.1 contains a path traversal vulnerability in lib/Compose.php that allows authenticated attackers to read arbitrary files from the server filesystem by embedding traversal sequences after a CKEditor path prefix in img…","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","cvssSource":"cna","cwe":["CWE-22"],"vendor":"horde","product":"imp","affected":["imp < 7.0.1"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-07-01T18:41:12.206279Z"},"published":"2026-07-01","updated":"2026-11-08","sourceUpdated":"2026-11-08T14:07:03.667Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-58451","references":[{"url":"https://github.com/horde/imp/releases/tag/v7.0.1","label":"imp 7.0.1 Release Notes"},{"url":"https://github.com/horde/imp/pull/85","label":"Fix PR"},{"url":"https://github.com/horde/imp/commit/fba972fab72ee6871e5d56e6390bee38593085de","label":"Fix Commit"},{"url":"https://www.horde.org/apps/imp","label":"Project Webpage"},{"url":"https://www.vulncheck.com/advisories/horde-imp-path-traversal-via-compose-php-img-src"},{"url":"https://blog.evan.lat/posts/CVE-2026-58451/","label":"Researcher Disclosure"}],"tags":["cve.org"],"epss":0.00564,"epssPercentile":0.47144,"ingestedAt":"2026-11-08T14:51:22.291Z","slug":"CVE-2026-58451","body":"## Overview\n\nHorde IMP before 7.0.1 contains a path traversal vulnerability in lib/Compose.php that allows authenticated attackers to read arbitrary files from the server filesystem by embedding traversal sequences after a CKEditor path prefix in img src URLs. Attackers can bypass the stripos() prefix validation by appending sequences such as traversal segments after the matching prefix, causing file_get_contents() to read sensitive files whose contents are then exfiltrated as MIME parts in outgoing email; unauthenticated exploitation is also achievable via CSRF against an active authenticated session.\n\n## Affected\n\n- `imp < 7.0.1`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}