{"id":"CVE-2026-59799","title":"Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow.\n\nThis issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and …","summary":"Improper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow.\n\nThis issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and …","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-269"],"vendor":"apache","product":"cloudstack","affected":["cloudstack >= 4.18.0.0, < 4.20.3.1","cloudstack >= 4.21.0.0, < 4.22.1.1"],"patched":["cloudstack 4.22.1.1"],"published":"2026-08-21","updated":"2026-10-16","sourceUpdated":"2026-10-16T15:10:00.103","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-59799","references":[{"url":"https://lists.apache.org/thread/g6cwddtjrwbh1d56wjz4cfp3fzfm4kbc","label":"security@apache.org"}],"tags":["nvd"],"epss":0.00604,"epssPercentile":0.48685,"ingestedAt":"2026-10-27T18:52:09.891Z","slug":"CVE-2026-59799","body":"## Overview\n\nImproper Privilege Management vulnerability in Apache CloudStack's Two-factor authentication plugin allowing bypass of the two-factor authentication disable flow.\n\nThis issue affects Apache CloudStack: from 4.18.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0.\n\nUsers are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.\n\n## Affected\n\n- `cloudstack >= 4.18.0.0, < 4.20.3.1`\n- `cloudstack >= 4.21.0.0, < 4.22.1.1`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `cloudstack 4.22.1.1`","depth":"twilight","depthScore":49,"depthScoreParts":{"impact":48.4,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}