{"id":"CVE-2026-60088","title":"PraisonAI before 4.6.78 fails to validate file path references in custom command templates, allowing attackers to read files outside the workspace","summary":"PraisonAI before 4.6.78 fails to validate file path references in custom command templates, allowing attackers to read files outside the workspace. Attackers can include path traversal sequences like @../outside_secret.txt or absolute pa…","severity":"medium","cvss":5.5,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","cwe":["CWE-22","CWE-200"],"published":"2026-07-11","updated":"2026-07-11","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-60088","references":[{"url":"https://github.com/MervinPraison/PraisonAI/commit/3aa9cbc2bd49c23a32be0a89a5e620d13d843eab","label":"disclosure@vulncheck.com"},{"url":"https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-xpx6-x8c2-mw5w","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/praisonai-before-path-traversal-via-custom-commands","label":"disclosure@vulncheck.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-60088"},{"url":"https://github.com/advisories/GHSA-xpx6-x8c2-mw5w"},{"url":"https://github.com/MervinPraison/PraisonAI"},{"url":"https://pypi.org/project/praisonai"}],"tags":["nvd","ghsa","pip","osv"],"ingestedAt":"2026-07-11T23:16:21.083Z","epss":0.00219,"epssPercentile":0.12307,"aliases":["GHSA-xpx6-x8c2-mw5w","PYSEC-2026-4261"],"ecosystem":"pip","vendor":"praisonai","product":"praisonai","affected":["praisonai <= 4.6.77"],"patched":["praisonai 4.6.78"],"slug":"CVE-2026-60088","body":"## Overview\n\nPraisonAI before 4.6.78 fails to validate file path references in custom command templates, allowing attackers to read files outside the workspace. Attackers can include path traversal sequences like @../outside_secret.txt or absolute paths in project command files to exfiltrate process-readable files into model prompts.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-60088)\n\nAffected packages:\n\n- `praisonai <= 4.6.77`\n\nPatched in:\n\n- `praisonai 4.6.78`\n\nSource: https://github.com/advisories/GHSA-xpx6-x8c2-mw5w","depth":"sunlit","depthScore":30,"depthScoreParts":{"impact":30.3,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}