{"id":"CVE-2026-61848","title":"Crass: Non-ASCII characters cause superlinear CPU consumption","summary":"Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, when Crass parses input containing `non-ASCII characters`, inefficiencies in tracking the positions of `multi-byte characters` r…","severity":"medium","cvss":6.3,"cvssVector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L","cvssSource":"cna","cwe":["CWE-400"],"vendor":"rgrove","product":"crass","affected":["crass < 1.0.7"],"published":"2026-10-30","updated":"2026-10-30","sourceUpdated":"2026-10-30T18:45:20.036Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-61848","references":[{"url":"https://github.com/rgrove/crass/security/advisories/GHSA-8vfg-2r28-hvhj","label":"https://github.com/rgrove/crass/security/advisories/GHSA-8vfg-2r28-hvhj"},{"url":"https://github.com/rgrove/crass/releases/tag/v1.0.7","label":"https://github.com/rgrove/crass/releases/tag/v1.0.7"},{"url":"http://github.com/rgrove/crass/commit/da29664648bf80a97a6439e030a4814291c9afa5","label":"http://github.com/rgrove/crass/commit/da29664648bf80a97a6439e030a4814291c9afa5"},{"url":"https://github.com/advisories/GHSA-8vfg-2r28-hvhj"}],"tags":["cve.org","ghsa","rubygems"],"epss":0.00486,"epssPercentile":0.41938,"aliases":["GHSA-8vfg-2r28-hvhj"],"ecosystem":"rubygems","patched":["crass 1.0.7"],"ingestedAt":"2026-10-29T16:38:25.970Z","slug":"CVE-2026-61848","body":"## Overview\n\nCrass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, when Crass parses input containing `non-ASCII characters`, inefficiencies in tracking the positions of `multi-byte characters` result in superlinear parsing time. An attacker-controlled CSS input consisting of many `non-ASCII characters` can therefore cause excessive CPU consumption and potentially denial of service. This issue is fixed in version 1.0.7.\n\n## Affected\n\n- `crass < 1.0.7`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-61848)\n\nAffected packages:\n\n- `crass < 1.0.7`\n\nPatched in:\n\n- `crass 1.0.7`\n\nSource: https://github.com/advisories/GHSA-8vfg-2r28-hvhj","depth":"sunlit","depthScore":35,"depthScoreParts":{"impact":34.7,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":233195,"id":"CVE-2026-61848","ts":1793895954791,"field":"cvss","old":null,"new":"6.3"}]}