{"id":"CVE-2026-63030","title":"WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL In…","summary":"WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL In…","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-436"],"vendor":"wordpress","product":"wordpress","affected":["wordpress >= 6.9, < 6.9.5","wordpress >= 7.0, < 7.0.2"],"patched":["wordpress 7.0.2"],"published":"2026-07-17","updated":"2026-10-08","sourceUpdated":"2026-10-08T10:35:50.787","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-63030","references":[{"url":"https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-ff9f-jf42-662q","label":"contact@wpscan.com"},{"url":"https://wordpress.org/news/2026/07/wordpress-7-0-2-release/","label":"contact@wpscan.com"},{"url":"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-63030","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"}],"tags":["nvd","kev","in-the-wild","exploit-available","cve.org"],"epss":0.10649,"epssPercentile":0.95774,"kev":true,"kevDateAdded":"2026-07-21","kevDueDate":"2026-07-24","kevRansomware":false,"exploited":true,"exploits":{"github":79,"githubRepos":["https://github.com/Icex0/wp2shell-poc","https://github.com/0xsha/wp2shell","https://github.com/ZephrFish/wp2shell-scanner"],"metasploit":["auxiliary/scanner/http/wordpress_wp2shell_sqli","exploit/multi/http/wp_batch_desync_rce"],"nuclei":["CVE-2026-63030"],"checkedAt":"2026-10-27T19:06:41.700Z"},"exploitAvailable":true,"ssvc":{"exploitation":"active","automatable":"yes","technicalImpact":"total","timestamp":"2026-07-22T03:55:47.123838Z"},"ingestedAt":"2026-07-18T21:25:08.032Z","slug":"CVE-2026-63030","body":"## Overview\n\nWordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.\n\n## Affected\n\n- `wordpress >= 6.9, < 6.9.5`\n- `wordpress >= 7.0, < 7.0.2`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `wordpress 7.0.2`","depth":"hadal","depthScore":81,"depthScoreParts":{"impact":53.9,"likelihood":2.1,"exploitation":25,"ransomware":0},"changes":[{"seq":210783,"id":"CVE-2026-63030","ts":1790326075190,"field":"epss","old":"0.97271","new":"0.10119"},{"seq":5392,"id":"CVE-2026-63030","ts":1788887278736,"field":"exploit_available","old":"false","new":"true"},{"seq":4275,"id":"CVE-2026-63030","ts":1788886392771,"field":"exploit_available","old":"true","new":"false"},{"seq":3024,"id":"CVE-2026-63030","ts":1788883056395,"field":"exploit_available","old":"false","new":"true"},{"seq":2053,"id":"CVE-2026-63030","ts":1788882460883,"field":"exploit_available","old":"true","new":"false"},{"seq":1126,"id":"CVE-2026-63030","ts":1788881897680,"field":"exploit_available","old":"false","new":"true"},{"seq":97,"id":"CVE-2026-63030","ts":1784920498994,"field":"epss","old":"0.38599","new":"0.97923"},{"seq":78,"id":"CVE-2026-63030","ts":1784747475904,"field":"epss","old":"0.08946","new":"0.38599"},{"seq":74,"id":"CVE-2026-63030","ts":1784660985010,"field":"exploited","old":"false","new":"true"},{"seq":73,"id":"CVE-2026-63030","ts":1784660985010,"field":"kev","old":"false","new":"true"}]}