{"id":"CVE-2026-72698","title":"Grav CMS before 2.0.16 fails to filter system, site, and theme configuration arrays in sandboxed Twig renders, allowing content editors to read sensitive configuration values","summary":"Grav CMS before 2.0.16 fails to filter system, site, and theme configuration arrays in sandboxed Twig renders, allowing content editors to read sensitive configuration values. Attackers with page-content edit access can access raw config…","severity":"medium","cvss":6.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","cwe":["CWE-200"],"vendor":"getgrav","product":"grav","affected":["grav < 2.0.16"],"patched":["getgrav/grav 2.0.16"],"published":"2026-08-25","updated":"2026-10-12","sourceUpdated":"2026-10-12T15:10:00.207","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-72698","references":[{"url":"https://github.com/getgrav/grav/security/advisories/GHSA-p597-crqc-m349","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/grav-cms-before-information-disclosure-via-twig-sandbox-bypass","label":"disclosure@vulncheck.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-72698"},{"url":"https://github.com/advisories/GHSA-p597-crqc-m349"}],"tags":["nvd","cve.org","ghsa","composer"],"epss":0.00409,"epssPercentile":0.35002,"aliases":["GHSA-p597-crqc-m349"],"ecosystem":"composer","ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-08-26T15:55:37.588962Z"},"ingestedAt":"2026-09-17T20:28:02.778Z","slug":"CVE-2026-72698","body":"## Overview\n\nGrav CMS before 2.0.16 fails to filter system, site, and theme configuration arrays in sandboxed Twig renders, allowing content editors to read sensitive configuration values. Attackers with page-content edit access can access raw configuration arrays including secrets like cache credentials by using dot notation in Twig templates, bypassing the config_denied_paths restrictions.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-72698)\n\nAffected packages:\n\n- `getgrav/grav < 2.0.16`\n\nPatched in:\n\n- `getgrav/grav 2.0.16`\n\nSource: https://github.com/advisories/GHSA-p597-crqc-m349","depth":"sunlit","depthScore":36,"depthScoreParts":{"impact":35.8,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":218159,"id":"CVE-2026-72698","ts":1791478456331,"field":"severity","old":"high","new":"medium"}]}