{"id":"CVE-2026-72766","title":"n8n before 1.123.67 Arbitrary File Read via Send Email Node","summary":"n8n before 1.123.67, 2.x before 2.31.5, and 2.32.x before 2.32.1 contain a type confusion vulnerability in the Send Email node, which does not enforce that its message fields are strings. A crafted non-string value supplied from a workfl…","severity":"high","cvss":8.2,"cvssVector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N","cvssSource":"cna","cwe":["CWE-843"],"vendor":"n8n-io","product":"n8n","affected":["n8n < 1.123.67","n8n >= 2.32.0 < 2.32.1","n8n >= 2.0.0-rc.0 < 2.31.5"],"ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-08-14T19:50:38.898583Z"},"published":"2026-08-11","updated":"2026-10-29","sourceUpdated":"2026-10-29T21:16:38.939Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-72766","references":[{"url":"https://github.com/n8n-io/n8n/security/advisories/GHSA-2x35-3fw4-9jr4","label":"GitHub Security Advisory (GHSA-2x35-3fw4-9jr4)"},{"url":"https://www.vulncheck.com/advisories/n8n-before-arbitrary-file-read-via-send-email-node","label":"VulnCheck Advisory: n8n before 1.123.67 Arbitrary File Read via Send Email Node"}],"tags":["cve.org"],"epss":0.00444,"epssPercentile":0.38636,"ingestedAt":"2026-11-03T08:39:35.592Z","slug":"CVE-2026-72766","body":"## Overview\n\nn8n before 1.123.67, 2.x before 2.31.5, and 2.32.x before 2.32.1 contain a type confusion vulnerability in the Send Email node, which does not enforce that its message fields are strings. A crafted non-string value supplied from a workflow expression into the text or HTML body field can be interpreted by the underlying mail library (Nodemailer) as a file path or URL, allowing arbitrary local file disclosure and server-side request forgery (SSRF). Exploitation requires a pre-existing active workflow with an unauthenticated webhook, valid SMTP credentials configured on the node, and untrusted input mapped directly into the body field; this is not a default configuration.\n\n## Affected\n\n- `n8n < 1.123.67`\n- `n8n >= 2.32.0 < 2.32.1`\n- `n8n >= 2.0.0-rc.0 < 2.31.5`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":45,"depthScoreParts":{"impact":45.1,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}