{"id":"CVE-2026-73259","title":"Mongoose is an embedded web server and network library","summary":"Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can send a crafted percent-encoded request path to a deployment using MG_ENABLE_DIRLIST and persuade a user to visit it. The mg_http_serve_dir() and…","severity":"medium","cvss":5.4,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","cwe":["CWE-79"],"vendor":"cesanta","product":"mongoose","affected":["mongoose < 7.22"],"patched":["mongoose 7.22"],"published":"2026-08-20","updated":"2026-09-29","sourceUpdated":"2026-09-29T15:51:55.453","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-73259","references":[{"url":"https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869e71","label":"security-advisories@github.com"},{"url":"https://github.com/cesanta/mongoose/pull/3611","label":"security-advisories@github.com"},{"url":"https://github.com/cesanta/mongoose/releases/tag/7.22","label":"security-advisories@github.com"},{"url":"https://github.com/cesanta/mongoose/security/advisories/GHSA-9cwm-487w-h25w","label":"security-advisories@github.com"},{"url":"https://github.com/cesanta/mongoose/security/advisories/GHSA-9cwm-487w-h25w","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"}],"tags":["nvd"],"epss":0.00408,"epssPercentile":0.3488,"ingestedAt":"2026-09-09T21:22:45.545Z","slug":"CVE-2026-73259","body":"## Overview\n\nMongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can send a crafted percent-encoded request path to a deployment using MG_ENABLE_DIRLIST and persuade a user to visit it. The mg_http_serve_dir() and listdir() path in src/http.c places the decoded request URI into the title and h1 elements without HTML entity encoding. The resulting reflected cross-site scripting executes in the Mongoose origin and can expose session data or perform actions as the victim. This issue is fixed in version 7.22.\n\n## Affected\n\n- `mongoose < 7.22`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `mongoose 7.22`","depth":"sunlit","depthScore":30,"depthScoreParts":{"impact":29.7,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}