{"id":"CVE-2026-73260","title":"Mongoose is an embedded web server and network library","summary":"Mongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg…","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","cwe":["CWE-125"],"published":"2026-10-14","updated":"2026-10-14","sourceUpdated":"2026-10-14T19:17:19.840","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-73260","references":[{"url":"https://github.com/cesanta/mongoose/commit/a8b4ae95db3c2db85e5ad9db3fefaeebb5f7b43e","label":"security-advisories@github.com"},{"url":"https://github.com/cesanta/mongoose/releases/tag/7.23","label":"security-advisories@github.com"},{"url":"https://github.com/cesanta/mongoose/security/advisories/GHSA-f6wr-mg35-p25g","label":"security-advisories@github.com"}],"tags":["nvd","cve.org","exploit-available"],"ingestedAt":"2026-10-14T19:49:57.615Z","vendor":"cesanta","product":"mongoose","affected":["mongoose < 7.23"],"epss":0.0023,"epssPercentile":0.13759,"exploitAvailable":true,"ssvc":{"exploitation":"poc","automatable":"yes","technicalImpact":"partial","timestamp":"2026-10-20T01:49:51.017897Z"},"slug":"CVE-2026-73260","body":"## Overview\n\nMongoose is an embedded web server and network library. Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a long-form DER element length fits within the remaining certificate buffer. In mg_der_to_tlv() and mg_der_next(), a peer-controlled length can advance the parser beyond the certificate and underflow the remaining uint32_t length, causing mg_tls_parse_cert_der() to continue walking an invalid pointer. An unauthenticated malicious TLS server, or a client presenting a certificate to a server configured for client certificates, can trigger an out-of-bounds read and denial of service during the handshake. This issue is fixed in version 7.23.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"midnight","depthScore":53,"depthScoreParts":{"impact":41.3,"likelihood":0,"exploitation":12,"ransomware":0},"changes":[{"seq":225338,"id":"CVE-2026-73260","ts":1792464733570,"field":"exploit_available","old":"false","new":"true"}]}