{"id":"CVE-2026-73627","title":"JupyterLab (pip package 'jupyterlab') versions >=4.1.0,<=4.5.9 and >=4.6.0,<=4.6.1 contain a plugin manager lock-rule enforcement bypass","summary":"JupyterLab (pip package 'jupyterlab') versions >=4.1.0,<=4.5.9 and >=4.6.0,<=4.6.1 contain a plugin manager lock-rule enforcement bypass. Two server-side enforcement gaps allow an authenticated user to circumvent administrator lock rules…","severity":"high","cvss":7.1,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N","cwe":["CWE-602","CWE-414"],"vendor":"Red Hat","product":"Red Hat OpenShift AI 2.25","affected":["migration_toolkit_for_applications 8","openshift_ai_rhoai","openshift_ai 2.25"],"patched":["openshift_ai 2.25"],"published":"2026-08-13","updated":"2026-09-30","sourceUpdated":"2026-09-30T18:18:39.947","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-73627","references":[{"url":"https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-h5v5-8746-g7mm","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/jupyterlab-plugin-manager-lock-rule-enforcement-bypass","label":"disclosure@vulncheck.com"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-73627.json"},{"url":"https://access.redhat.com/security/cve/CVE-2026-73627"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2515245"},{"url":"https://www.cve.org/CVERecord?id=CVE-2026-73627"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-73627"},{"url":"https://access.redhat.com/errata/RHSA-2026:65126"},{"url":"https://github.com/jupyterlab/jupyterlab/pull/19184"},{"url":"https://github.com/jupyterlab/jupyterlab/pull/19185"},{"url":"https://github.com/jupyterlab/jupyterlab/pull/19186"},{"url":"https://github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2c"},{"url":"https://github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432"},{"url":"https://github.com/jupyterlab/jupyterlab"},{"url":"https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10"},{"url":"https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2"},{"url":"https://access.redhat.com/errata/RHSA-2026:73987"},{"url":"https://access.redhat.com/errata/RHSA-2026:84734"}],"tags":["nvd","csaf","vex","red-hat","cve.org","osv","pip"],"epss":0.00422,"epssPercentile":0.363,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-08-15T03:13:31.123307Z"},"cvssSource":"vendor","scores":{"vendor":7.1,"cna":6},"ingestedAt":"2026-09-09T21:22:45.533Z","aliases":["GHSA-h5v5-8746-g7mm","BIT-jupyterlab-2026-73627"],"ecosystem":"pip","slug":"CVE-2026-73627","body":"## Overview\n\nJupyterLab (pip package 'jupyterlab') versions >=4.1.0,<=4.5.9 and >=4.6.0,<=4.6.1 contain a plugin manager lock-rule enforcement bypass. Two server-side enforcement gaps allow an authenticated user to circumvent administrator lock rules by making direct requests to the /lab/api/plugins endpoint, enabling or disabling plugins that were locked — including child plugins of multi-plugin extensions and plugins locked via the 'lock all' mechanism. This can impact data integrity and bypass hardening or restrictions (e.g., download/upload limits) implemented through locked plugins. Fixed in versions 4.6.2 and 4.5.10.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Vendor advisories\n\n- **RHSA-2026:65126** · Red Hat · fixed in: Red Hat OpenShift AI 2.25 · released 2026-09-08 · [advisory](https://access.redhat.com/errata/RHSA-2026:65126)\n- **Red Hat VEX** · Moderate · affected: Red Hat OpenShift AI (RHOAI) · no fix planned: Red Hat OpenShift AI (RHOAI) · updated 2026-10-19 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-73627.json)\n- **RHSA-2026:73987** · Red Hat · fixed in: Red Hat OpenShift AI 3.3 · released 2026-09-30 · [advisory](https://access.redhat.com/errata/RHSA-2026:73987)\n- **RHSA-2026:84734** · Red Hat · fixed in: Red Hat OpenShift AI 3.4 · released 2026-10-19 · [advisory](https://access.redhat.com/errata/RHSA-2026:84734)\n\n## Package advisory (CVE-2026-73627)\n\nAffected packages:\n\n- `jupyterlab >= 4.6.0, < 4.6.2`\n- `jupyterlab >= 4.1.0, < 4.5.10`\n\nPatched in:\n\n- `jupyterlab 4.6.2`\n- `jupyterlab 4.5.10`\n\nSource: https://osv.dev/vulnerability/GHSA-h5v5-8746-g7mm","depth":"twilight","depthScore":39,"depthScoreParts":{"impact":39.1,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":205544,"id":"CVE-2026-73627","ts":1789576724795,"field":"cvss","old":null,"new":"7.1"},{"seq":205543,"id":"CVE-2026-73627","ts":1789576724795,"field":"severity","old":"none","new":"high"}]}