{"id":"CVE-2026-73856","title":"ModSecurity: Response Body Inspection Bypass","summary":"ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 until 3.0.17, src/transaction.cc compares a response Content-Type value against SecResponseBodyMimeType entries cas…","severity":"high","cvss":8.6,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","cvssSource":"cna","cwe":["CWE-178"],"vendor":"owasp-modsecurity","product":"ModSecurity","affected":["ModSecurity >= 3.0.0, < 3.0.17"],"published":"2026-11-05","updated":"2026-11-05","sourceUpdated":"2026-11-05T15:50:09.778Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-73856","references":[{"url":"https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-vmg8-j66p-vgvw","label":"https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-vmg8-j66p-vgvw"},{"url":"https://github.com/owasp-modsecurity/ModSecurity/commit/23ccd9202114f8313df3773f7992782fd9949c98","label":"https://github.com/owasp-modsecurity/ModSecurity/commit/23ccd9202114f8313df3773f7992782fd9949c98"},{"url":"https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v3.0.17","label":"https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v3.0.17"}],"tags":["cve.org"],"ingestedAt":"2026-11-05T21:36:00.925Z","slug":"CVE-2026-73856","body":"## Overview\n\nModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 until 3.0.17, src/transaction.cc compares a response Content-Type value against SecResponseBodyMimeType entries case-sensitively. A mixed-case response media type that is semantically equivalent to a configured lowercase type can therefore be treated as unconfigured, causing ModSecurity to skip RESPONSE_BODY inspection. An unauthenticated requester can then receive response content that a phase 4 rule would otherwise block, including sensitive error or debug data. This issue is fixed in version 3.0.17.\n\n## Affected\n\n- `ModSecurity >= 3.0.0, < 3.0.17`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":47,"depthScoreParts":{"impact":47.3,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}