{"id":"CVE-2026-74877","title":"openssl_encrypt versions before 1.4.0 contain a missing ownership verification vulnerability in the revoke_key method that allows authenticated clients to revoke any other client's key","summary":"openssl_encrypt versions before 1.4.0 contain a missing ownership verification vulnerability in the revoke_key method that allows authenticated clients to revoke any other client's key. Attackers can revoke arbitrary keys by providing a …","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-639"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.0"],"patched":["openssl_encrypt 1.4.0"],"published":"2026-08-17","updated":"2026-10-08","sourceUpdated":"2026-10-08T16:17:39.583","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-74877","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-hvc7-763r-4f3h","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-missing-ownership-verification-via-revoke-key","label":"disclosure@vulncheck.com"},{"url":"https://github.com/jahlives/openssl_encrypt/commit/05e45f393886b5bf7e924d2dd42099a9dd37f91d"},{"url":"https://github.com/jahlives/openssl_encrypt"}],"tags":["nvd","cve.org","osv","pip"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-08-18T14:36:43.072806Z"},"epss":0.00451,"epssPercentile":0.39005,"aliases":["GHSA-hvc7-763r-4f3h"],"ecosystem":"pip","ingestedAt":"2026-08-18T12:28:09.042Z","slug":"CVE-2026-74877","body":"## Overview\n\nopenssl_encrypt versions before 1.4.0 contain a missing ownership verification vulnerability in the revoke_key method that allows authenticated clients to revoke any other client's key. Attackers can revoke arbitrary keys by providing a valid ML-DSA signature, bypassing the intended ownership restriction.\n\n## Affected\n\n- `openssl_encrypt < 1.4.0`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `openssl_encrypt 1.4.0`\n\n## Package advisory (CVE-2026-74877)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.0`\n\nPatched in:\n\n- `openssl-encrypt 1.4.0`\n\nSource: https://osv.dev/vulnerability/GHSA-hvc7-763r-4f3h","depth":"twilight","depthScore":48,"depthScoreParts":{"impact":48.4,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":214475,"id":"CVE-2026-74877","ts":1790869829087,"field":"cvss","old":null,"new":"8.8"},{"seq":214474,"id":"CVE-2026-74877","ts":1790869829087,"field":"severity","old":"medium","new":"high"}]}