{"id":"CVE-2026-74888","title":"openssl_encrypt before 1.4.0 Non-Standard PBKDF2 Key Derivation","summary":"openssl_encrypt versions before 1.4.0 use a non-standard PBKDF2 key derivation construction with iterations=1 per call in an outer loop, creating a KDF whose security properties have not been formally analyzed. Attackers can exploit this…","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","cvssSource":"cna","cwe":["CWE-327"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.0"],"ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-08-17T12:48:14.297282Z"},"published":"2026-08-17","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:20:59.221Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-74888","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-743f-89fg-x288","label":"GitHub Security Advisory (GHSA-743f-89fg-x288)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-non-standard-pbkdf2-key-derivation","label":"VulnCheck Advisory: openssl_encrypt before 1.4.0 Non-Standard PBKDF2 Key Derivation"}],"tags":["cve.org","osv","pip"],"epss":0.00272,"epssPercentile":0.19402,"aliases":["PYSEC-2026-3764","GHSA-743f-89fg-x288"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.0"],"ingestedAt":"2026-09-02T19:31:25.578Z","slug":"CVE-2026-74888","body":"## Overview\n\nopenssl_encrypt versions before 1.4.0 use a non-standard PBKDF2 key derivation construction with iterations=1 per call in an outer loop, creating a KDF whose security properties have not been formally analyzed. Attackers can exploit this weakened key derivation to more efficiently crack passwords protecting legacy encrypted files compared to standard PBKDF2 implementations.\n\n## Affected\n\n- `openssl_encrypt < 1.4.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-74888)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.0`\n\nPatched in:\n\n- `openssl-encrypt 1.4.0`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3764","depth":"twilight","depthScore":41,"depthScoreParts":{"impact":41.3,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":214455,"id":"CVE-2026-74888","ts":1790869826121,"field":"cvss","old":null,"new":"7.5"},{"seq":214454,"id":"CVE-2026-74888","ts":1790869826121,"field":"severity","old":"none","new":"high"}]}