{"id":"CVE-2026-74899","title":"openssl_encrypt before 1.4.0 Sandbox Escape via Type Hierarchy","summary":"openssl_encrypt versions before 1.4.0 contain a sandbox escape vulnerability in IsolatedPluginExecutor that exposes Python type objects in restricted exec() builtins. Attackers can traverse the Python class hierarchy via __class__.__mro_…","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-95"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.0"],"ssvc":{"exploitation":"poc","automatable":"yes","technicalImpact":"total","timestamp":"2026-08-18T14:40:11.591350Z"},"exploitAvailable":true,"published":"2026-08-17","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:05.055Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-74899","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-m25m-ggxg-239c","label":"GitHub Security Advisory (GHSA-m25m-ggxg-239c)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-sandbox-escape-via-type-hierarchy","label":"VulnCheck Advisory: openssl_encrypt before 1.4.0 Sandbox Escape via Type Hierarchy"},{"url":"https://github.com/siyuan-note/siyuan/security/advisories/GHSA-43jx-gxq4-jpjc"}],"tags":["cve.org","exploit-available","osv","pip"],"epss":0.0075,"epssPercentile":0.54758,"aliases":["PYSEC-2026-3727"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.0"],"ingestedAt":"2026-08-29T19:29:14.910Z","slug":"CVE-2026-74899","body":"## Overview\n\nopenssl_encrypt versions before 1.4.0 contain a sandbox escape vulnerability in IsolatedPluginExecutor that exposes Python type objects in restricted exec() builtins. Attackers can traverse the Python class hierarchy via __class__.__mro__.__subclasses__() to access system functions and execute arbitrary OS commands.\n\n## Affected\n\n- `openssl_encrypt < 1.4.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-74899)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.0`\n\nPatched in:\n\n- `openssl-encrypt 1.4.0`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3727","depth":"abyssal","depthScore":66,"depthScoreParts":{"impact":53.9,"likelihood":0.2,"exploitation":12,"ransomware":0},"changes":[{"seq":214441,"id":"CVE-2026-74899","ts":1790869824250,"field":"exploit_available","old":"false","new":"true"},{"seq":214440,"id":"CVE-2026-74899","ts":1790869824250,"field":"cvss","old":null,"new":"9.8"},{"seq":214439,"id":"CVE-2026-74899","ts":1790869824250,"field":"severity","old":"none","new":"critical"}]}