{"id":"CVE-2026-74900","title":"openssl_encrypt before 1.4.0 Weak Shared Secret via PQC Simulation Mode","summary":"openssl_encrypt versions before 1.4.0 contain a critical vulnerability in pqc.py where KEM decapsulation failures silently fall back to simulation mode, generating a deterministic shared secret from only 16 bytes of the private key and p…","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-391"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.0"],"ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"total","timestamp":"2026-08-17T12:46:53.410833Z"},"published":"2026-08-17","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:05.831Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-74900","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-p3gq-pcg9-qvfv","label":"GitHub Security Advisory (GHSA-p3gq-pcg9-qvfv)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-weak-shared-secret-via-pqc-simulation-mode","label":"VulnCheck Advisory: openssl_encrypt before 1.4.0 Weak Shared Secret via PQC Simulation Mode"}],"tags":["cve.org","osv","pip"],"epss":0.00559,"epssPercentile":0.46393,"aliases":["PYSEC-2026-3772","GHSA-p3gq-pcg9-qvfv"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.0"],"ingestedAt":"2026-09-02T19:31:25.909Z","slug":"CVE-2026-74900","body":"## Overview\n\nopenssl_encrypt versions before 1.4.0 contain a critical vulnerability in pqc.py where KEM decapsulation failures silently fall back to simulation mode, generating a deterministic shared secret from only 16 bytes of the private key and publicly available encapsulated key data. Attackers who obtain 16 bytes of the private key can compute the shared secret and decrypt all ciphertext, as the fallback triggers on any KEM failure without raising an error.\n\n## Affected\n\n- `openssl_encrypt < 1.4.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-74900)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.0`\n\nPatched in:\n\n- `openssl-encrypt 1.4.0`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3772","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":53.9,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":214438,"id":"CVE-2026-74900","ts":1790869823985,"field":"cvss","old":null,"new":"9.8"},{"seq":214437,"id":"CVE-2026-74900","ts":1790869823985,"field":"severity","old":"none","new":"critical"}]}