{"id":"CVE-2026-75806","title":"Issue summary: An established DTLS 1.2 association using an AEAD cipher suite\ncan be terminated by a single unauthenticated datagram whose encrypted\nfragment is shorter than the mandatory explicit IV and authentication tag\noverhead.\n\nImp…","summary":"Issue summary: An established DTLS 1.2 association using an AEAD cipher suite\ncan be terminated by a single unauthenticated datagram whose encrypted\nfragment is shorter than the mandatory explicit IV and authentication tag\noverhead.\n\nImp…","severity":"medium","cvss":5.3,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","cwe":["CWE-1284"],"vendor":"openssl","product":"openssl","affected":["openssl >= 1.1.1, < 1.1.1zj","openssl >= 3.0.0, < 3.0.23","openssl >= 3.4.0, < 3.4.8","openssl >= 3.5.0, < 3.5.9","openssl >= 3.6.0, < 3.6.5","openssl >= 4.0.0, < 4.0.3"],"patched":["openssl 4.0.3"],"published":"2026-09-29","updated":"2026-10-08","sourceUpdated":"2026-10-08T01:20:33.453","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-75806","references":[{"url":"https://github.com/openssl/openssl/commit/04728a289a823e68137f88da016cb9ede307217d","label":"openssl-security@openssl.org"},{"url":"https://github.com/openssl/openssl/commit/050b275cd671a6eed1d6457642d41a5a77aab972","label":"openssl-security@openssl.org"},{"url":"https://github.com/openssl/openssl/commit/3a4589d015a9049d47b66f186cf50a8711343a1d","label":"openssl-security@openssl.org"},{"url":"https://github.com/openssl/openssl/commit/5af82fefbaf2b5fec2fc0e1d87f112844902f01d","label":"openssl-security@openssl.org"},{"url":"https://openssl-library.org/news/secadv/20260929.txt","label":"openssl-security@openssl.org"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-75806.json"},{"url":"https://access.redhat.com/security/cve/CVE-2026-75806"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2543260"},{"url":"https://www.cve.org/CVERecord?id=CVE-2026-75806"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-75806"}],"tags":["nvd","cve.org","csaf","vex","red-hat"],"epss":0.01104,"epssPercentile":0.65601,"ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-09-29T16:52:47.298458Z"},"ingestedAt":"2026-09-29T16:39:33.268Z","slug":"CVE-2026-75806","body":"## Overview\n\nIssue summary: An established DTLS 1.2 association using an AEAD cipher suite\ncan be terminated by a single unauthenticated datagram whose encrypted\nfragment is shorter than the mandatory explicit IV and authentication tag\noverhead.\n\nImpact summary: An attacker who can send a datagram that is routed to an\nexisting DTLS 1.2 association can tear that association down without knowing\nany key material. This is a Denial of Service limited to the targeted\nassociation. There is no memory safety or confidentiality impact.\n\nCWE: CWE-1284: Improper Validation of Specified Quantity in Input\n\nDescription: In TLS 1.2 and DTLS 1.2 every record protected by an AEAD cipher\nsuite carries an explicit IV followed by the ciphertext and an authentication\ntag. When decrypting such a record the record layer passed the record length to\nthe cipher implementation before checking that the record was long enough to\ncontain the explicit IV and the tag. For a record shorter than that overhead the\ncipher implementation rejected the impossible length, and the record layer\ntreated this as an internal failure and raised a fatal internal_error alert\ninstead of treating the record as one that failed authentication.\n\nIn TLS 1.2 the same record causes a fatal internal_error alert instead of the\nexpected bad_record_mac alert. Since any undecryptable record already\nterminates a TLS connection, this is a protocol conformance issue rather than\na security issue in TLS.\n\nThe fix validates the record length against the explicit IV and tag length\nbefore any AEAD processing, so that TLS reports bad_record_mac and DTLS\nsilently discards the record.\n\nFIPS impact: no\nThe affected code is outside the FIPS module boundary.\n\n## Affected\n\n- `openssl >= 1.1.1, < 1.1.1zj`\n- `openssl >= 3.0.0, < 3.0.23`\n- `openssl >= 3.4.0, < 3.4.8`\n- `openssl >= 3.5.0, < 3.5.9`\n- `openssl >= 3.6.0, < 3.6.5`\n- `openssl >= 4.0.0, < 4.0.3`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `openssl 4.0.3`\n\n## Vendor advisories\n\n- **Red Hat VEX** · Moderate · affected: Red Hat Developer Hub, Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9, … · no fix planned: Red Hat Enterprise Linux 6, Red Hat Developer Hub, Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 7, … · updated 2026-09-29 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-75806.json)","depth":"sunlit","depthScore":29,"depthScoreParts":{"impact":29.2,"likelihood":0.2,"exploitation":0,"ransomware":0},"changes":[{"seq":212861,"id":"CVE-2026-75806","ts":1790703711076,"field":"cvss","old":null,"new":"5.3"},{"seq":212860,"id":"CVE-2026-75806","ts":1790703711076,"field":"severity","old":"none","new":"medium"}]}