{"id":"CVE-2026-77936","title":"Letta through 0.16.8 Insecure Default Configuration Unauthenticated API and PostgreSQL Access","summary":"Letta through 0.16.8 ships a compose.yaml that does not enable LETTA_SERVER_SECURE, so the password middleware is never added and all API routes are unauthenticated, and it exposes a superuser PostgreSQL port with default credentials. Re…","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-1188"],"vendor":"letta-ai","product":"letta","affected":["letta <= 0.16.8"],"ssvc":{"exploitation":"poc","automatable":"yes","technicalImpact":"total","timestamp":"2026-10-20T16:04:32.766807Z"},"exploitAvailable":true,"published":"2026-10-20","updated":"2026-10-20","sourceUpdated":"2026-10-20T16:07:28.161Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-77936","references":[{"url":"https://www.lasso.security/vulnerability-database/cve-2026-77936","label":"Lasso.security Advisory"},{"url":"https://github.com/letta-ai/letta/blob/1131535716e8a31c9a437f8695e25ac98f203a24/compose.yaml#L17"},{"url":"https://github.com/letta-ai/letta/blob/1131535716e8a31c9a437f8695e25ac98f203a24/letta/server/rest_api/app.py#L799"},{"url":"https://www.vulncheck.com/advisories/letta-through-0.16.8-insecure-default-configuration-unauthenticated-api-and-postgresql-access","label":"VulnCheck Advisory: Letta through 0.16.8 Insecure Default Configuration Unauthenticated API and PostgreSQL Access"}],"tags":["cve.org","exploit-available"],"epss":0.00589,"epssPercentile":0.47945,"ingestedAt":"2026-10-20T01:49:42.623Z","slug":"CVE-2026-77936","body":"## Overview\n\nLetta through 0.16.8 ships a compose.yaml that does not enable LETTA_SERVER_SECURE, so the password middleware is never added and all API routes are unauthenticated, and it exposes a superuser PostgreSQL port with default credentials. Remote attackers can execute arbitrary Python via POST /v1/tools/run, manage /v1/admin users, or run OS commands via COPY PROGRAM.\n\n## Affected\n\n- `letta <= 0.16.8`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"abyssal","depthScore":66,"depthScoreParts":{"impact":53.9,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":226019,"id":"CVE-2026-77936","ts":1792516454921,"field":"exploit_available","old":"false","new":"true"}]}