{"id":"CVE-2026-80733","title":"net: remove WARN_ON_ONCE() from sk_mc_loop()","summary":"In the Linux kernel, the following vulnerability has been resolved:\n\nnet: remove WARN_ON_ONCE() from sk_mc_loop()\n\nsk_mc_loop() can be called for sockets that are neither AF_INET\nnor AF_INET6 (e.g. AF_PACKET sockets when sending packets …","severity":"none","vendor":"Linux","product":"Linux","affected":["Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < 97133c4d42654578fab95abe47359ebe784dde18","Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < f625c742b33dc137c209dd13d1c5f12b1c18d71c","Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < ad7fa2f411cb30f63d6725f111be134064cdb718","Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < d2adc4e80b29e58b5162ae09f0f657a215806c8c","Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < ad7dbb1d14b1b4406eca8ef9478e8de312ba0cfe","Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < c8f256dc849205ccb2bd78bd99a3497b972b44e0","Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < 0d75f2c1d0764efa756ad9c1e078d8c09ea8fc1f","Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < b8a39a09ae4eaae04309e1e38ed6a1101d967496","Linux c91f81773cd4bbebfe744e9ab30a7ce093f9b930","Linux c8c30b2b17f2133e953850c547e3902c3a3d80e2","Linux 3fe207e4637a2e792c46a08666aa722f77d7f8f7","Linux >= 3.14.40 < 3.15","Linux >= 3.18.13 < 3.19","Linux >= 3.19.6 < 3.20","Linux 4.0"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-11-06T17:02:55.348385Z"},"published":"2026-09-03","updated":"2026-11-06","sourceUpdated":"2026-11-06T17:05:53.381Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-80733","references":[{"url":"https://git.kernel.org/stable/c/97133c4d42654578fab95abe47359ebe784dde18"},{"url":"https://git.kernel.org/stable/c/f625c742b33dc137c209dd13d1c5f12b1c18d71c"},{"url":"https://git.kernel.org/stable/c/ad7fa2f411cb30f63d6725f111be134064cdb718"},{"url":"https://git.kernel.org/stable/c/d2adc4e80b29e58b5162ae09f0f657a215806c8c"},{"url":"https://git.kernel.org/stable/c/ad7dbb1d14b1b4406eca8ef9478e8de312ba0cfe"},{"url":"https://git.kernel.org/stable/c/c8f256dc849205ccb2bd78bd99a3497b972b44e0"},{"url":"https://git.kernel.org/stable/c/0d75f2c1d0764efa756ad9c1e078d8c09ea8fc1f"},{"url":"https://git.kernel.org/stable/c/b8a39a09ae4eaae04309e1e38ed6a1101d967496"}],"tags":["cve.org"],"epss":0.00177,"epssPercentile":0.07259,"ingestedAt":"2026-11-06T18:00:12.534Z","slug":"CVE-2026-80733","body":"## Overview\n\nIn the Linux kernel, the following vulnerability has been resolved:\n\nnet: remove WARN_ON_ONCE() from sk_mc_loop()\n\nsk_mc_loop() can be called for sockets that are neither AF_INET\nnor AF_INET6 (e.g. AF_PACKET sockets when sending packets via raw/packet\nsocket over virtual devices such as VRF or ipvlan).\n\nIn such cases, sk_family is not AF_INET/AF_INET6 and sk_mc_loop() falls\nthrough the switch statement and triggers WARN_ON_ONCE(1).\n\nNon-INET sockets do not support IP_MULTICAST_LOOP or IPV6_MULTICAST_LOOP\noptions, so loopback should default to true without generating a warning.\n\n## Affected\n\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < 97133c4d42654578fab95abe47359ebe784dde18`\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < f625c742b33dc137c209dd13d1c5f12b1c18d71c`\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < ad7fa2f411cb30f63d6725f111be134064cdb718`\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < d2adc4e80b29e58b5162ae09f0f657a215806c8c`\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < ad7dbb1d14b1b4406eca8ef9478e8de312ba0cfe`\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < c8f256dc849205ccb2bd78bd99a3497b972b44e0`\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < 0d75f2c1d0764efa756ad9c1e078d8c09ea8fc1f`\n- `Linux >= f60e5990d9c1424af9dbca60a23ba2a1c7c1ce90 < b8a39a09ae4eaae04309e1e38ed6a1101d967496`\n- `Linux c91f81773cd4bbebfe744e9ab30a7ce093f9b930`\n- `Linux c8c30b2b17f2133e953850c547e3902c3a3d80e2`\n- `Linux 3fe207e4637a2e792c46a08666aa722f77d7f8f7`\n- `Linux >= 3.14.40 < 3.15`\n- `Linux >= 3.18.13 < 3.19`\n- `Linux >= 3.19.6 < 3.20`\n- `Linux 4.0`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":3,"depthScoreParts":{"impact":2.8,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}