{"id":"CVE-2026-81680","title":"openssl_encrypt before 1.4.9 Authentication Bypass via Recovery Slot Removal","summary":"openssl_encrypt versions before 1.4.9 fail to authenticate recovery-slot presence in envelope-format encrypted files, allowing attackers to remove recovery slots without re-encrypting the payload. Attackers can modify the file header to …","severity":"medium","cvss":4,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","cvssSource":"cna","cwe":["CWE-347"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.9"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-08-27T19:23:50.488382Z"},"published":"2026-08-27","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:16.940Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-81680","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-grhj-cpmg-f5mx","label":"GitHub Security Advisory (GHSA-grhj-cpmg-f5mx)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-authentication-bypass-via-recovery-slot-removal","label":"VulnCheck Advisory: openssl_encrypt before 1.4.9 Authentication Bypass via Recovery Slot Removal"}],"tags":["cve.org","osv","pip"],"epss":0.00204,"epssPercentile":0.10296,"aliases":["PYSEC-2026-3957","GHSA-grhj-cpmg-f5mx"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.9"],"scores":{"cna":4,"osv":5.3},"ingestedAt":"2026-09-12T03:13:01.743Z","slug":"CVE-2026-81680","body":"## Overview\n\nopenssl_encrypt versions before 1.4.9 fail to authenticate recovery-slot presence in envelope-format encrypted files, allowing attackers to remove recovery slots without re-encrypting the payload. Attackers can modify the file header to delete recovery-slot fields and bypass authentication, silently removing recovery paths the owner deliberately added.\n\n## Affected\n\n- `openssl_encrypt < 1.4.9`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-81680)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.9`\n\nPatched in:\n\n- `openssl-encrypt 1.4.9`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3957","depth":"sunlit","depthScore":22,"depthScoreParts":{"impact":22,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":214427,"id":"CVE-2026-81680","ts":1790869818525,"field":"cvss","old":"5.3","new":"4"}]}