{"id":"CVE-2026-81685","title":"openssl_encrypt before 1.4.9 Text Injection via Recovery Slot Metadata","summary":"openssl_encrypt versions before 1.4.9 fail to sanitize recovery-slot metadata in the desktop GUI, allowing attackers to inject control characters and line separators into the irreversible-removal confirmation dialog. Attackers can craft …","severity":"low","cvss":3.3,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","cvssSource":"cna","cwe":["CWE-116"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.9"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-08-27T19:24:40.534525Z"},"published":"2026-08-27","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:20.159Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-81685","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-49h2-qmcq-wvvc","label":"GitHub Security Advisory (GHSA-49h2-qmcq-wvvc)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-text-injection-via-recovery-slot-metadata","label":"VulnCheck Advisory: openssl_encrypt before 1.4.9 Text Injection via Recovery Slot Metadata"}],"tags":["cve.org","osv","pip"],"epss":0.0025,"epssPercentile":0.16301,"aliases":["PYSEC-2026-3793","GHSA-49h2-qmcq-wvvc"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.9"],"ingestedAt":"2026-09-03T19:32:12.027Z","slug":"CVE-2026-81685","body":"## Overview\n\nopenssl_encrypt versions before 1.4.9 fail to sanitize recovery-slot metadata in the desktop GUI, allowing attackers to inject control characters and line separators into the irreversible-removal confirmation dialog. Attackers can craft encrypted files with malicious slot identifiers containing bidi overrides or line-separator characters to forge warning text and deceive users during file removal operations.\n\n## Affected\n\n- `openssl_encrypt < 1.4.9`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-81685)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.9`\n\nPatched in:\n\n- `openssl-encrypt 1.4.9`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3793","depth":"sunlit","depthScore":18,"depthScoreParts":{"impact":18.2,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":214422,"id":"CVE-2026-81685","ts":1790869817731,"field":"cvss","old":null,"new":"3.3"},{"seq":214421,"id":"CVE-2026-81685","ts":1790869817731,"field":"severity","old":"none","new":"low"}]}