{"id":"CVE-2026-81686","title":"openssl_encrypt before 1.4.9 D-Bus Properties Authorization Bypass","summary":"openssl_encrypt 1.4.x before 1.4.9 contains an optional D-Bus crypto service whose org.freedesktop.DBus.Properties.Set method performs neither a polkit authorization check nor value validation. Any local user on the system bus can call S…","severity":"medium","cvss":6.2,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","cvssSource":"cna","cwe":["CWE-20"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.9"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-08-27T18:06:14.323611Z"},"published":"2026-08-27","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:20.770Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-81686","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-7fhx-8rmv-qjj3","label":"GitHub Security Advisory (GHSA-7fhx-8rmv-qjj3)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-d-bus-properties-authorization-bypass","label":"VulnCheck Advisory: openssl_encrypt before 1.4.9 D-Bus Properties Authorization Bypass"}],"tags":["cve.org","osv","pip"],"epss":0.00139,"epssPercentile":0.03231,"aliases":["PYSEC-2026-3794","GHSA-7fhx-8rmv-qjj3"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.9"],"scores":{"cna":6.2,"osv":5.5},"ingestedAt":"2026-09-03T19:32:12.069Z","slug":"CVE-2026-81686","body":"## Overview\n\nopenssl_encrypt 1.4.x before 1.4.9 contains an optional D-Bus crypto service whose org.freedesktop.DBus.Properties.Set method performs neither a polkit authorization check nor value validation. Any local user on the system bus can call Set without authorization and set MaxConcurrentOperations (to 0/negative, causing the concurrency gate to refuse all subsequent operations, or to a huge value removing the limit) or the unbounded DefaultTimeout, resulting in a persistent denial of service of the root daemon. The D-Bus service exists only on the 1.4.x line and was removed in 1.5.x.\n\n## Affected\n\n- `openssl_encrypt < 1.4.9`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-81686)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.9`\n\nPatched in:\n\n- `openssl-encrypt 1.4.9`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3794","depth":"sunlit","depthScore":34,"depthScoreParts":{"impact":34.1,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":214416,"id":"CVE-2026-81686","ts":1790869816936,"field":"cvss","old":"5.5","new":"6.2"}]}