{"id":"CVE-2026-81694","title":"verify-usb before 1.4.9 Output Injection via Unsanitized Filenames","summary":"openssl-encrypt (pip package, versions <= 1.4.8) fails to sanitize filenames read from untrusted drive data (outside the AES-GCM authenticated manifest) before printing them in the verify-usb command's output. An attacker can plant filen…","severity":"low","cvss":3.3,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","cvssSource":"cna","cwe":["CWE-117"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.9"],"ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"total","timestamp":"2026-08-27T18:47:58.198454Z"},"published":"2026-08-27","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:26.011Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-81694","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-c793-rj9w-r3wg","label":"GitHub Security Advisory (GHSA-c793-rj9w-r3wg)"},{"url":"https://www.vulncheck.com/advisories/verify-usb-before-1.4.9-output-injection-via-unsanitized-filenames","label":"VulnCheck Advisory: verify-usb before 1.4.9 Output Injection via Unsanitized Filenames"}],"tags":["cve.org","osv","pip"],"epss":0.0025,"epssPercentile":0.16301,"aliases":["PYSEC-2026-3960","GHSA-c793-rj9w-r3wg"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.9"],"ingestedAt":"2026-09-12T03:13:01.743Z","slug":"CVE-2026-81694","body":"## Overview\n\nopenssl-encrypt (pip package, versions <= 1.4.8) fails to sanitize filenames read from untrusted drive data (outside the AES-GCM authenticated manifest) before printing them in the verify-usb command's output. An attacker can plant filenames containing terminal cursor-movement and erase-line control bytes that repaint a forged PASSED verdict on screen, masking actual tamper detection. Fixed in 1.4.9 by routing drive-derived names through sanitize_for_display().\n\n## Affected\n\n- `openssl_encrypt < 1.4.9`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-81694)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.9`\n\nPatched in:\n\n- `openssl-encrypt 1.4.9`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3960","depth":"sunlit","depthScore":18,"depthScoreParts":{"impact":18.2,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":214409,"id":"CVE-2026-81694","ts":1790869815257,"field":"cvss","old":null,"new":"3.3"},{"seq":214408,"id":"CVE-2026-81694","ts":1790869815257,"field":"severity","old":"none","new":"low"}]}