{"id":"CVE-2026-81714","title":"openssl_encrypt before 1.4.9 Plugin Signing Trust Anchor Enrollment Bypass","summary":"openssl_encrypt (pip: openssl-encrypt) versions <= 1.4.8 use suffix-tolerant fingerprint matching in enroll_trust_key when binding a plugin-signing trust anchor. An operator who confirms a short (forgeable, ~32-bit) GPG key id could unkn…","severity":"high","cvss":7,"cvssVector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-347"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.9"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-08-27T18:21:49.871096Z"},"published":"2026-08-27","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:35.038Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-81714","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-xg52-638v-jc5m","label":"GitHub Security Advisory (GHSA-xg52-638v-jc5m)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-plugin-signing-trust-anchor-enrollment-bypass","label":"VulnCheck Advisory: openssl_encrypt before 1.4.9 Plugin Signing Trust Anchor Enrollment Bypass"}],"tags":["cve.org","osv","pip"],"epss":0.00199,"epssPercentile":0.09592,"aliases":["PYSEC-2026-3799","GHSA-xg52-638v-jc5m"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.9"],"ingestedAt":"2026-09-03T19:32:12.282Z","slug":"CVE-2026-81714","body":"## Overview\n\nopenssl_encrypt (pip: openssl-encrypt) versions <= 1.4.8 use suffix-tolerant fingerprint matching in enroll_trust_key when binding a plugin-signing trust anchor. An operator who confirms a short (forgeable, ~32-bit) GPG key id could unknowingly enroll an attacker's colliding key as a trusted anchor, which then vouches for malicious plugins under the ENFORCE signature policy. Version 1.4.9 fixes this by requiring the confirmed value to exactly match the full primary-key fingerprint (case-insensitive, whitespace-stripped).\n\n## Affected\n\n- `openssl_encrypt < 1.4.9`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-81714)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.9`\n\nPatched in:\n\n- `openssl-encrypt 1.4.9`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3799","depth":"twilight","depthScore":39,"depthScoreParts":{"impact":38.5,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":214390,"id":"CVE-2026-81714","ts":1790869811725,"field":"cvss","old":null,"new":"7"},{"seq":214389,"id":"CVE-2026-81714","ts":1790869811725,"field":"severity","old":"none","new":"high"}]}