{"id":"CVE-2026-81719","title":"openssl_encrypt before 1.4.9 Remote Code Execution via Plugin","summary":"openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process …","severity":"high","cvss":7.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-94"],"vendor":"jahlives","product":"openssl_encrypt","affected":["openssl_encrypt < 1.4.9"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-08-27T18:27:57.459770Z"},"published":"2026-08-27","updated":"2026-10-01","sourceUpdated":"2026-10-01T15:21:38.281Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-81719","references":[{"url":"https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-587j-4r3v-cm2c","label":"GitHub Security Advisory (GHSA-587j-4r3v-cm2c)"},{"url":"https://www.vulncheck.com/advisories/openssl-encrypt-before-1.4.9-remote-code-execution-via-plugin","label":"VulnCheck Advisory: openssl_encrypt before 1.4.9 Remote Code Execution via Plugin"}],"tags":["cve.org","osv","pip"],"epss":0.00436,"epssPercentile":0.37681,"aliases":["PYSEC-2026-3802","GHSA-587j-4r3v-cm2c"],"ecosystem":"pip","patched":["openssl-encrypt 1.4.9"],"ingestedAt":"2026-09-03T19:32:12.409Z","slug":"CVE-2026-81719","body":"## Overview\n\nopenssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.\n\n## Affected\n\n- `openssl_encrypt < 1.4.9`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-81719)\n\nAffected packages:\n\n- `openssl-encrypt < 1.4.9`\n\nPatched in:\n\n- `openssl-encrypt 1.4.9`\n\nSource: https://osv.dev/vulnerability/PYSEC-2026-3802","depth":"twilight","depthScore":43,"depthScoreParts":{"impact":42.9,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[{"seq":214386,"id":"CVE-2026-81719","ts":1790869810627,"field":"cvss","old":null,"new":"7.8"},{"seq":214385,"id":"CVE-2026-81719","ts":1790869810627,"field":"severity","old":"none","new":"high"}]}