{"id":"CVE-2026-82418","title":"IBM Watson Speech Services Cartridge is vulnerable to a Use After Free condition in cryptography wheels OpenSSL","summary":"IBM Watson Speech Services Cartridge 4.0.0 through 5.4.0 could allow a remote attacker to execute arbitrary code due to a use-after-free vulnerability.","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvssSource":"cna","cwe":["CWE-416"],"vendor":"IBM","product":"Watson Speech Services Cartridge","affected":["watson_speech_services_cartridge >= 4.0.0 <= 5.4.0"],"published":"2026-11-04","updated":"2026-11-04","sourceUpdated":"2026-11-04T21:03:52.429Z","source":"CVEORG","sourceUrl":"https://www.cve.org/CVERecord?id=CVE-2026-82418","references":[{"url":"https://www.ibm.com/support/pages/node/7293510"}],"tags":["cve.org"],"ingestedAt":"2026-11-05T21:36:00.587Z","epss":0.00442,"epssPercentile":0.38584,"slug":"CVE-2026-82418","body":"## Overview\n\nIBM Watson Speech Services Cartridge 4.0.0 through 5.4.0 could allow a remote attacker to execute arbitrary code due to a use-after-free vulnerability.\n\n## Affected\n\n- `watson_speech_services_cartridge >= 4.0.0 <= 5.4.0`\n\n## Remediation\n\nIBM strongly recommends addressing the vulnerability now.\nProduct(s)Version(s)Remediation/Fix/InstructionsIBM Watson Speech Services Cartridge5.4.0 Patch 8 The fix in 5.4.0 Patch 8 applies to all versions listed (4.0.0-5.4.0). The newest version of 5.4.0 with the included Patch 8 can be downloaded and installed from:\n https://www.ibm.com/docs/en/cloud-paks/cp-data/5.4.x","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":53.9,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}