{"id":"CVE-2026-84313","title":"Nginx UI is a web user interface for the Nginx web server","summary":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, POST /api/otp_enroll and POST /api/finish_passkey_register are registered outside RequireSecureSession and accept a normal authenticated session without verifying…","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","cwe":["CWE-287","CWE-306"],"vendor":"0xJacky","product":"nginx-ui","affected":["nginx-ui < 2.4.1"],"published":"2026-10-12","updated":"2026-10-15","sourceUpdated":"2026-10-15T14:17:29.597","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-84313","references":[{"url":"https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-gfrc-g87h-7h5w","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-gfrc-g87h-7h5w","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-84313"},{"url":"https://github.com/advisories/GHSA-gfrc-g87h-7h5w"},{"url":"https://github.com/0xJacky/nginx-ui"}],"tags":["nvd","cve.org","exploit-available","ghsa","go","osv"],"exploitAvailable":true,"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"total","timestamp":"2026-10-15T13:48:05.211053Z"},"epss":0.00542,"epssPercentile":0.45391,"ingestedAt":"2026-10-12T22:05:40.367Z","aliases":["GHSA-gfrc-g87h-7h5w","GO-2026-6786"],"ecosystem":"go","patched":["Nginx-UI 1.9.10-0.20260703131214-23d1934099b0"],"slug":"CVE-2026-84313","body":"## Overview\n\nNginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, POST /api/otp_enroll and POST /api/finish_passkey_register are registered outside RequireSecureSession and accept a normal authenticated session without verifying the current password. An attacker with a stolen JWT can bind an attacker-controlled TOTP secret when the victim has not already enabled TOTP, or can register an attacker-controlled passkey because that path has no equivalent existing-enrollment guard. These changes create persistent account access that can survive a password change and interfere with the legitimate user's authentication. This issue is fixed in version 2.4.1.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-84313)\n\nAffected packages:\n\n- `Nginx-UI < 1.9.10-0.20260703131214-23d1934099b0`\n\nPatched in:\n\n- `Nginx-UI 1.9.10-0.20260703131214-23d1934099b0`\n\nSource: https://github.com/advisories/GHSA-gfrc-g87h-7h5w","depth":"midnight","depthScore":61,"depthScoreParts":{"impact":48.4,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":222363,"id":"CVE-2026-84313","ts":1792073304598,"field":"exploit_available","old":"false","new":"true"}]}