{"id":"CVE-2026-84314","title":"Nginx UI is a web user interface for the Nginx web server","summary":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though…","severity":"high","cwe":["CWE-285","CWE-862"],"published":"2026-10-12","updated":"2026-10-13","sourceUpdated":"2026-10-13T18:17:25.927","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-84314","references":[{"url":"https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-84314"},{"url":"https://github.com/advisories/GHSA-2gc7-j998-5xx6"},{"url":"https://github.com/0xJacky/nginx-ui"}],"tags":["nvd","cve.org","exploit-available","ghsa","go","osv"],"epss":0.00419,"epssPercentile":0.36036,"ingestedAt":"2026-10-12T22:05:40.367Z","vendor":"0xJacky","product":"nginx-ui","affected":["nginx-ui < 2.4.1"],"cvss":8.7,"cvssVector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","exploitAvailable":true,"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"total","timestamp":"2026-10-13T17:31:07.190328Z"},"cvssSource":"cna","aliases":["GHSA-2gc7-j998-5xx6","GO-2026-6771"],"ecosystem":"go","patched":["github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0"],"slug":"CVE-2026-84314","body":"## Overview\n\nNginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the POST /api/users/:id user-management endpoint permits an authenticated user to change another user's password without passing RequireSecureSession, even though the self-service password-change path requires that step-up. An attacker with an authenticated account can change the initial administrator's password, invalidate existing administrator tokens, and then authenticate as the administrator. This issue is fixed in version 2.4.1.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-84314)\n\nAffected packages:\n\n- `github.com/0xJacky/Nginx-UI < 1.9.10-0.20260703131214-23d1934099b0`\n\nPatched in:\n\n- `github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0`\n\nSource: https://github.com/advisories/GHSA-2gc7-j998-5xx6","depth":"midnight","depthScore":60,"depthScoreParts":{"impact":47.8,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":221029,"id":"CVE-2026-84314","ts":1792027014230,"field":"exploit_available","old":"false","new":"true"},{"seq":221028,"id":"CVE-2026-84314","ts":1792027014230,"field":"cvss","old":null,"new":"8.7"},{"seq":221027,"id":"CVE-2026-84314","ts":1792027014230,"field":"severity","old":"none","new":"high"}]}