{"id":"CVE-2026-84319","title":"Nginx UI is a web user interface for the Nginx web server","summary":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the regular HTTP configuration API rejects restricted Nginx directives such as load_module, js_import, and js_content. However, the MCP configuration interface al…","severity":"high","cvss":8.3,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H","cwe":["CWE-693"],"published":"2026-10-12","updated":"2026-10-13","sourceUpdated":"2026-10-13T21:19:11.433","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-84319","references":[{"url":"https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-5r62-gj48-897x","label":"security-advisories@github.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-84319"},{"url":"https://github.com/advisories/GHSA-5r62-gj48-897x"},{"url":"https://github.com/0xJacky/nginx-ui"}],"tags":["nvd","cve.org","ghsa","go","osv"],"epss":0.0028,"epssPercentile":0.20386,"ingestedAt":"2026-10-12T22:05:40.369Z","vendor":"0xJacky","product":"nginx-ui","affected":["nginx-ui < 2.4.1"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-13T20:13:18.604078Z"},"aliases":["GHSA-5r62-gj48-897x","GO-2026-6774"],"ecosystem":"go","patched":["github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0"],"slug":"CVE-2026-84319","body":"## Overview\n\nNginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the regular HTTP configuration API rejects restricted Nginx directives such as load_module, js_import, and js_content. However, the MCP configuration interface allows a secondary authenticated user to write and apply equivalent restricted configuration content. This allows the user to load ngx_http_js_module.so, import attacker-controlled JavaScript, reload Nginx, and execute NJS in the Nginx worker context. This issue is fixed in version 2.4.1.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-84319)\n\nAffected packages:\n\n- `github.com/0xJacky/Nginx-UI < 1.9.10-0.20260703131214-23d1934099b0`\n\nPatched in:\n\n- `github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0`\n\nSource: https://github.com/advisories/GHSA-5r62-gj48-897x","depth":"twilight","depthScore":46,"depthScoreParts":{"impact":45.7,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}