{"id":"CVE-2026-84360","title":"Nginx UI is a web user interface for the Nginx web server","summary":"Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_a…","severity":"high","cvss":8.1,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","cwe":["CWE-288"],"published":"2026-10-12","updated":"2026-10-13","sourceUpdated":"2026-10-13T14:31:20.750","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-84360","references":[{"url":"https://github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/releases/tag/v2.4.1","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-vc32-4gwf-77xp","label":"security-advisories@github.com"},{"url":"https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-vc32-4gwf-77xp","label":"134c704f-9b21-4f2e-91b3-4a467353bcc0"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-84360"},{"url":"https://github.com/advisories/GHSA-vc32-4gwf-77xp"},{"url":"https://github.com/0xJacky/nginx-ui"}],"tags":["nvd","cve.org","exploit-available","ghsa","go","osv"],"epss":0.0042,"epssPercentile":0.36137,"ingestedAt":"2026-10-12T22:05:40.370Z","vendor":"0xJacky","product":"nginx-ui","affected":["nginx-ui < 2.4.1"],"exploitAvailable":true,"ssvc":{"exploitation":"poc","automatable":"no","technicalImpact":"partial","timestamp":"2026-10-13T14:00:07.727918Z"},"aliases":["GHSA-vc32-4gwf-77xp","GO-2026-6799"],"ecosystem":"go","patched":["github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0"],"slug":"CVE-2026-84360","body":"## Overview\n\nNginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-84360)\n\nAffected packages:\n\n- `github.com/0xJacky/Nginx-UI < 1.9.10-0.20260703131214-23d1934099b0`\n\nPatched in:\n\n- `github.com/0xJacky/Nginx-UI 1.9.10-0.20260703131214-23d1934099b0`\n\nSource: https://github.com/advisories/GHSA-vc32-4gwf-77xp","depth":"midnight","depthScore":57,"depthScoreParts":{"impact":44.6,"likelihood":0.1,"exploitation":12,"ransomware":0},"changes":[{"seq":220896,"id":"CVE-2026-84360","ts":1792026904205,"field":"exploit_available","old":"false","new":"true"}]}