{"id":"CVE-2026-8505","title":"IBM Langflow OSS 1.0.0 through 1.10.0 has a vulnerability in Langflow's webhook authentication logic allows unauthenticated users to trigger the execution of any flow","summary":"IBM Langflow OSS 1.0.0 through 1.10.0 has a vulnerability in Langflow's webhook authentication logic allows unauthenticated users to trigger the execution of any flow. The system incorrectly bypasses API key validation when the WEBHOOK_A…","severity":"critical","cvss":9.8,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","published":"2026-07-17","updated":"2026-07-18","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-8505","references":[{"url":"https://www.ibm.com/support/pages/node/7278921","label":"psirt@us.ibm.com"},{"url":"https://github.com/langflow-ai/langflow/security/advisories/GHSA-cf6m-vc3m-7cgm"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-8505"},{"url":"https://github.com/langflow-ai/langflow/pull/12845"},{"url":"https://github.com/langflow-ai/langflow/commit/cb6f7508dda83ead9c3e4417e96e4b5bd9a260c3"},{"url":"https://github.com/langflow-ai/langflow/releases/tag/v1.9.1"},{"url":"https://github.com/advisories/GHSA-cf6m-vc3m-7cgm"},{"url":"https://github.com/langflow-ai/langflow"},{"url":"https://pypi.org/project/langflow"}],"tags":["nvd","ghsa","pip","osv"],"epss":0.00719,"epssPercentile":0.53699,"ingestedAt":"2026-07-18T21:25:08.073Z","aliases":["GHSA-cf6m-vc3m-7cgm","PYSEC-2026-4233"],"ecosystem":"pip","vendor":"langflow","product":"langflow","affected":["langflow >= 1.7.0, <= 1.9.0"],"patched":["langflow 1.9.1"],"cwe":["CWE-306"],"slug":"CVE-2026-8505","body":"## Overview\n\nIBM Langflow OSS 1.0.0 through 1.10.0 has a vulnerability in Langflow's webhook authentication logic allows unauthenticated users to trigger the execution of any flow. The system incorrectly bypasses API key validation when the WEBHOOK_AUTH_ENABLE configuration is set to False (which is the default setting). This allows a remote attacker who knows a flow's UUID to execute it as if they were the owner, potentially leading to Remote Code Execution (RCE).\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-8505)\n\nAffected packages:\n\n- `langflow >= 1.7.0, <= 1.9.0`\n\nPatched in:\n\n- `langflow 1.9.1`\n\nSource: https://github.com/advisories/GHSA-cf6m-vc3m-7cgm","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":53.9,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}