{"id":"CVE-2026-86247","title":"Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations.\n\n\n\nThis issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, f…","summary":"Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations.\n\n\n\nThis issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, f…","severity":"high","cvss":7.4,"cvssVector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","cwe":["CWE-366"],"vendor":"apache","product":"tomcat_native","affected":["tomcat_native >= 1.3.0, < 1.3.9","tomcat_native >= 2.0.0, < 2.0.16"],"patched":["tomcat_native 2.0.16"],"published":"2026-09-23","updated":"2026-10-06","sourceUpdated":"2026-10-06T13:46:49.633","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-86247","references":[{"url":"https://lists.apache.org/thread/obsson6zhvfg0wsp2bx602l61ltj87r1","label":"security@apache.org"},{"url":"http://www.openwall.com/lists/oss-security/2026/09/23/33","label":"af854a3a-2127-422b-91ae-364da2661108"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-86247.json"},{"url":"https://access.redhat.com/security/cve/CVE-2026-86247"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2539393"},{"url":"https://www.cve.org/CVERecord?id=CVE-2026-86247"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-86247"}],"tags":["nvd","cve.org","csaf","vex","red-hat","score-dispute"],"epss":0.00202,"epssPercentile":0.10005,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-09-23T15:30:32.467469Z"},"scores":{"nvd":7.4,"vendor":4.8},"ingestedAt":"2026-09-23T13:24:43.399Z","slug":"CVE-2026-86247","body":"## Overview\n\nRace condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations.\n\n\n\nThis issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected.\n\n\n\nUsers are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.\n\n## Affected\n\n- `tomcat_native >= 1.3.0, < 1.3.9`\n- `tomcat_native >= 2.0.0, < 2.0.16`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `tomcat_native 2.0.16`\n\n## Vendor advisories\n\n- **Red Hat VEX** · Moderate · affected: Red Hat JBoss Web Server 5, Red Hat JBoss Web Server 6, Red Hat JBoss Web Server 7 · no fix planned: Red Hat JBoss Web Server 5, Red Hat JBoss Web Server 6, Red Hat JBoss Web Server 7 · updated 2026-10-01 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-86247.json)","depth":"twilight","depthScore":41,"depthScoreParts":{"impact":40.7,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[{"seq":209775,"id":"CVE-2026-86247","ts":1790180880468,"field":"cvss","old":null,"new":"7.4"},{"seq":209774,"id":"CVE-2026-86247","ts":1790180880468,"field":"severity","old":"none","new":"high"}]}