{"id":"CVE-2026-91813","title":"A vulnerability in Foxit PDF Editor/Reader’s update mechanism allows an update package to be replaced between download and high-privilege extraction due to insufficient file locking and integrity validation","summary":"A vulnerability in Foxit PDF Editor/Reader’s update mechanism allows an update package to be replaced between download and high-privilege extraction due to insufficient file locking and integrity validation. This could enable local attac…","severity":"high","cvss":8.8,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","cwe":["CWE-367"],"vendor":"foxit","product":"pdf_editor","affected":["pdf_editor <= 13.2.5.63482","pdf_editor >= 14.0.0.33046, <= 14.0.7.33751","pdf_editor >= 2023.1.0.15510, <= 2023.3.0.23028","pdf_editor >= 2024.1.0.23997, <= 2024.4.1.27687","pdf_editor >= 2025.1.0.27937, <= 2025.3.0.35737","pdf_editor >= 2026.1.0.36452, <= 2026.2.0.39747","pdf_reader <= 2026.2.0.39747"],"published":"2026-09-23","updated":"2026-10-08","sourceUpdated":"2026-10-08T14:01:22.210","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-91813","references":[{"url":"https://www.foxit.com/support/security-bulletins.html","label":"14984358-7092-470d-8f34-ade47a7658a2"}],"tags":["nvd","cve.org"],"epss":0.00091,"epssPercentile":0.00442,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-09-23T14:37:19.640678Z"},"ingestedAt":"2026-09-23T08:20:37.595Z","slug":"CVE-2026-91813","body":"## Overview\n\nA vulnerability in Foxit PDF Editor/Reader’s update mechanism allows an update package to be replaced between download and high-privilege extraction due to insufficient file locking and integrity validation. This could enable local attackers to execute arbitrary code with elevated privileges.\n\n## Affected\n\n- `pdf_editor <= 13.2.5.63482`\n- `pdf_editor >= 14.0.0.33046, <= 14.0.7.33751`\n- `pdf_editor >= 2023.1.0.15510, <= 2023.3.0.23028`\n- `pdf_editor >= 2024.1.0.23997, <= 2024.4.1.27687`\n- `pdf_editor >= 2025.1.0.27937, <= 2025.3.0.35737`\n- `pdf_editor >= 2026.1.0.36452, <= 2026.2.0.39747`\n- `pdf_reader <= 2026.2.0.39747`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"twilight","depthScore":48,"depthScoreParts":{"impact":48.4,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}