{"id":"CVE-2026-91817","title":"A heap-based out-of-bounds read vulnerability exists in Foxit PDF Editor/Reader’s handling of wide strings in embedded PDF JavaScript","summary":"A heap-based out-of-bounds read vulnerability exists in Foxit PDF Editor/Reader’s handling of wide strings in embedded PDF JavaScript. Insufficient validation of string-deletion ranges can cause an integer underflow, resulting in an out-…","severity":"medium","cvss":6.1,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H","cwe":["CWE-125"],"vendor":"foxit","product":"pdf_editor","affected":["pdf_editor <= 13.2.5.63482","pdf_editor >= 14.0.0.33046, <= 14.0.7.33751","pdf_editor >= 2023.1.0.15510, <= 2023.3.0.23028","pdf_editor >= 2024.1.0.23997, <= 2024.4.1.27687","pdf_editor >= 2025.1.0.27937, <= 2025.3.0.35737","pdf_editor >= 2026.1.0.36452, <= 2026.2.0.39747","pdf_reader <= 2026.2.0.39747"],"published":"2026-09-23","updated":"2026-10-01","sourceUpdated":"2026-10-01T20:23:59.847","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-91817","references":[{"url":"https://www.foxit.com/support/security-bulletins.html","label":"14984358-7092-470d-8f34-ade47a7658a2"}],"tags":["nvd","cve.org"],"epss":0.00153,"epssPercentile":0.04374,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-09-23T14:22:00.125904Z"},"ingestedAt":"2026-09-23T08:20:37.597Z","slug":"CVE-2026-91817","body":"## Overview\n\nA heap-based out-of-bounds read vulnerability exists in Foxit PDF Editor/Reader’s handling of wide strings in embedded PDF JavaScript. Insufficient validation of string-deletion ranges can cause an integer underflow, resulting in an out-of-bounds read and application crash.\n\n## Affected\n\n- `pdf_editor <= 13.2.5.63482`\n- `pdf_editor >= 14.0.0.33046, <= 14.0.7.33751`\n- `pdf_editor >= 2023.1.0.15510, <= 2023.3.0.23028`\n- `pdf_editor >= 2024.1.0.23997, <= 2024.4.1.27687`\n- `pdf_editor >= 2025.1.0.27937, <= 2025.3.0.35737`\n- `pdf_editor >= 2026.1.0.36452, <= 2026.2.0.39747`\n- `pdf_reader <= 2026.2.0.39747`\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.","depth":"sunlit","depthScore":34,"depthScoreParts":{"impact":33.6,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}