{"id":"CVE-2026-92599","title":"joi (npm package `joi`, hapi.js) versions >=17.2.0 <17.13.7 and >=18.0.0 <18.2.6 are vulnerable to regular expression denial of service in the `Joi.string().isoDate()` validation rule","summary":"joi (npm package `joi`, hapi.js) versions >=17.2.0 <17.13.7 and >=18.0.0 <18.2.6 are vulnerable to regular expression denial of service in the `Joi.string().isoDate()` validation rule. One of the regular expressions the rule applies to t…","severity":"high","cvss":7.5,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","cwe":["CWE-1333"],"vendor":"hapijs","product":"joi","affected":["joi >= 17.2.0 < 17.13.7","joi >= 18.0.0 < 18.2.6"],"published":"2026-09-16","updated":"2026-09-22","sourceUpdated":"2026-09-22T20:25:55.870","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-92599","references":[{"url":"https://github.com/hapijs/joi/security/advisories/GHSA-6h2x-m376-mqjq","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/joi-before-17.13.7-and-18.2.6-redos-via-isodate","label":"disclosure@vulncheck.com"},{"url":"https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-92599.json"},{"url":"https://access.redhat.com/security/cve/CVE-2026-92599"},{"url":"https://bugzilla.redhat.com/show_bug.cgi?id=2538354"},{"url":"https://www.cve.org/CVERecord?id=CVE-2026-92599"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-92599"},{"url":"https://access.redhat.com/errata/RHSA-2026:68821"},{"url":"https://access.redhat.com/errata/RHSA-2026:68926"},{"url":"https://access.redhat.com/errata/RHSA-2026:68778"},{"url":"https://github.com/hapijs/joi/pull/3143"},{"url":"https://github.com/hapijs/joi/pull/3145"},{"url":"https://github.com/hapijs/joi/commit/115e7b58d5eaaecc5e9b7093d41899ad6fb053ec"},{"url":"https://github.com/hapijs/joi/commit/e70df424c367f2976db63b089504413744a21245"},{"url":"https://github.com/advisories/GHSA-6h2x-m376-mqjq"}],"tags":["nvd","cve.org","csaf","vex","red-hat","ghsa","npm"],"epss":0.00582,"epssPercentile":0.47592,"ssvc":{"exploitation":"none","automatable":"yes","technicalImpact":"partial","timestamp":"2026-09-18T20:06:34.166545Z"},"ingestedAt":"2026-09-16T22:06:50.926Z","patched":["hardened_images"],"aliases":["GHSA-6h2x-m376-mqjq"],"ecosystem":"npm","slug":"CVE-2026-92599","body":"## Overview\n\njoi (npm package `joi`, hapi.js) versions >=17.2.0 <17.13.7 and >=18.0.0 <18.2.6 are vulnerable to regular expression denial of service in the `Joi.string().isoDate()` validation rule. One of the regular expressions the rule applies to the input is unanchored, so a valid ISO date followed by a long run of fractional-second digits causes the regex engine to restart its search from every position in the string, yielding time proportional to the square of the input length (about 1.4 s for 64 KB of digits and about 22 s for 256 KB). A remote attacker who can supply a string to an isoDate validation can stall the application with a single request. Fixed in 17.13.7 and 18.2.6; as a workaround, cap the length of the string before it reaches joi.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Vendor advisories\n\n- **RHSA-2026:68821** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-09-18 · [advisory](https://access.redhat.com/errata/RHSA-2026:68821)\n- **RHSA-2026:68926** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-09-18 · [advisory](https://access.redhat.com/errata/RHSA-2026:68926)\n- **RHSA-2026:68778** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-09-17 · [advisory](https://access.redhat.com/errata/RHSA-2026:68778)\n- **Red Hat VEX** · Important · affected: Migration Toolkit for Containers, Red Hat Data Grid 8, Red Hat Enterprise Linux 8, Red Hat OpenShift AI (RHOAI), Red Hat OpenShift Container Platform 4 · no fix planned: Red Hat Data Grid 8, Migration Toolkit for Containers, Red Hat Enterprise Linux 8, Red Hat OpenShift AI (RHOAI), … · updated 2026-10-02 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-92599.json)\n\n## Package advisory (CVE-2026-92599)\n\nAffected packages:\n\n- `joi >= 17.2.0, < 17.13.7`\n- `joi >= 18.0.0, < 18.2.6`\n\nPatched in:\n\n- `joi 17.13.7`\n- `joi 18.2.6`\n\nSource: https://github.com/advisories/GHSA-6h2x-m376-mqjq","depth":"twilight","depthScore":41,"depthScoreParts":{"impact":41.3,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}