{"id":"CVE-2026-92951","title":"vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation","summary":"vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by re…","severity":"critical","cvss":9.9,"cvssVector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","cwe":["CWE-706","CWE-829","CWE-863"],"vendor":"patriksimek","product":"vm2","affected":["vm2 < 3.11.7"],"published":"2026-09-17","updated":"2026-09-17","sourceUpdated":"2026-09-17T20:18:59.610","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-92951","references":[{"url":"https://github.com/patriksimek/vm2/security/advisories/GHSA-c48m-32m9-vx93","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/vm2-before-3.11.7-module-allowlist-bypass-via-custom-resolver","label":"disclosure@vulncheck.com"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2026-92951"},{"url":"https://github.com/patriksimek/vm2/commit/ab4ee7d803e8c80155e9eb3672226bddbca4aa9c"},{"url":"https://github.com/patriksimek/vm2/releases/tag/v3.11.7"},{"url":"https://github.com/advisories/GHSA-c48m-32m9-vx93"}],"tags":["nvd","cve.org","ghsa","npm"],"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"total","timestamp":"2026-09-17T18:57:28.158352Z"},"ingestedAt":"2026-09-17T14:19:30.988Z","epss":0.00539,"epssPercentile":0.45178,"aliases":["GHSA-c48m-32m9-vx93"],"ecosystem":"npm","patched":["vm2 3.11.7"],"slug":"CVE-2026-92951","body":"## Overview\n\nvm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.\n\n## Remediation\n\nRefer to the linked advisories for vendor-supplied fixes and affected version ranges.\n\n## Package advisory (CVE-2026-92951)\n\nAffected packages:\n\n- `vm2 <= 3.11.6`\n\nPatched in:\n\n- `vm2 3.11.7`\n\nSource: https://github.com/advisories/GHSA-c48m-32m9-vx93","depth":"midnight","depthScore":55,"depthScoreParts":{"impact":54.5,"likelihood":0.1,"exploitation":0,"ransomware":0},"changes":[]}