{"id":"CVE-2026-93587","title":"ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource…","summary":"ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource…","severity":"low","cvss":3.3,"cvssVector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","cwe":["CWE-400"],"vendor":"imagemagick","product":"imagemagick","affected":["imagemagick < 6.9.13-56","imagemagick >= 7.0.0-0, < 7.1.2-31"],"patched":["imagemagick 7.1.2-31"],"published":"2026-09-18","updated":"2026-10-16","sourceUpdated":"2026-10-16T18:44:46.247","source":"NVD","sourceUrl":"https://nvd.nist.gov/vuln/detail/CVE-2026-93587","references":[{"url":"https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-89wq-f8f6-2j2v","label":"disclosure@vulncheck.com"},{"url":"https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-31-policy-bypass-via-pcd-decoder","label":"disclosure@vulncheck.com"}],"tags":["nvd","cve.org"],"epss":0.00121,"epssPercentile":0.01863,"ssvc":{"exploitation":"none","automatable":"no","technicalImpact":"partial","timestamp":"2026-09-18T18:05:54.426521Z"},"ingestedAt":"2026-09-18T13:41:41.667Z","slug":"CVE-2026-93587","body":"## Overview\n\nImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.\n\n## Affected\n\n- `imagemagick < 6.9.13-56`\n- `imagemagick >= 7.0.0-0, < 7.1.2-31`\n\n## Remediation\n\nUpgrade past the affected range:\n\n- `imagemagick 7.1.2-31`","depth":"sunlit","depthScore":18,"depthScoreParts":{"impact":18.2,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}