{"id":"GHSA-w5r9-j49j-2m55","title":"Duplicate Advisory : Flowise has arbitrary file access due to missing chat flow id validation","summary":"Duplicate Advisory : Flowise has arbitrary file access due to missing chat flow id validation","severity":"critical","cvss":9.8,"cwe":["CWE-73"],"vendor":"flowise","product":"flowise","ecosystem":"npm","affected":["flowise >= 2.2.8, < 3.0.6"],"patched":["flowise 3.0.6"],"published":"2026-06-26","updated":"2026-11-03","sourceUpdated":"2026-11-03T17:35:34Z","source":"GHSA","sourceUrl":"https://github.com/advisories/GHSA-w5r9-j49j-2m55","references":[{"url":"https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-q67q-549q-p849"},{"url":"https://nvd.nist.gov/vuln/detail/CVE-2025-71334"},{"url":"https://github.com/FlowiseAI/Flowise/commit/8bd3de41533de78e4ef6c980e5704a1f9cb7ae6f"},{"url":"https://github.com/FlowiseAI/Flowise/commit/c2b830f279e454e8b758da441016b2234f220ac7"},{"url":"https://www.vulncheck.com/advisories/flowise-arbitrary-file-access-via-missing-chat-flow-id-validation"},{"url":"https://github.com/advisories/GHSA-w5r9-j49j-2m55"}],"tags":["ghsa","npm"],"ingestedAt":"2026-11-03T17:50:48.251Z","slug":"GHSA-w5r9-j49j-2m55","body":"## Overview\n\n### Duplicate Advisory\nThis advisory has been withdrawn because it is a duplicate of GHSA-q67q-549q-p849. This link is maintained to preserve external references.\n\n### Original Description\n\nFlowise before 3.0.6 (affected versions 2.2.8 and earlier) contains an arbitrary file access vulnerability due to missing validation that the chatflowId and chatId parameters are UUIDs or numbers in file handling operations. By supplying a path-traversal value (e.g., '../../../../../tmp') as the chatflow id, an unauthenticated attacker can use the /api/v1/chatflows endpoint (via addBase64FilesToStorage) to write arbitrary files, and the /api/v1/get-upload-file and /api/v1/openai-assistants-file/download endpoints (via streamStorageFile) to read arbitrary files. Arbitrary file write may lead to remote code execution.\n\n## Affected packages\n\n- `flowise >= 2.2.8, < 3.0.6`\n\n## Remediation\n\nUpgrade to a patched release:\n\n- `flowise 3.0.6`","depth":"midnight","depthScore":54,"depthScoreParts":{"impact":53.9,"likelihood":0,"exploitation":0,"ransomware":0},"changes":[]}